aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2020-01-01 20:36:47 +0900
committerHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2020-01-01 20:36:47 +0900
commite46f32a397369a7d36ac653ce0465f962cae5759 (patch)
tree5eb723bd391861e1644547ce037ec5b30a751f41
parentdb01daea8a39766cebc495ccae138f928c681837 (diff)
cluster-receiver: Update omxh264dec supportsandbox/harunobu.kurokawa/ces_2020_debug1231
Change-Id: I2fccb29a9d65c9b542e5eda568f5a78a3e20e264 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
-rw-r--r--recipes-demo-hmi/cluster-receiver/cluster-receiver/0001-Update-omxh264dec-parameter.patch33
-rw-r--r--recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bbappend5
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-demo-hmi/cluster-receiver/cluster-receiver/0001-Update-omxh264dec-parameter.patch b/recipes-demo-hmi/cluster-receiver/cluster-receiver/0001-Update-omxh264dec-parameter.patch
new file mode 100644
index 0000000..228fc38
--- /dev/null
+++ b/recipes-demo-hmi/cluster-receiver/cluster-receiver/0001-Update-omxh264dec-parameter.patch
@@ -0,0 +1,33 @@
+From 3647b15c75a7e0d4d68d6f5c9963b811c60d2bc8 Mon Sep 17 00:00:00 2001
+From: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+Date: Fri, 13 Dec 2019 07:58:54 +0900
+Subject: [PATCH] Update omxh264dec parameter
+
+Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+---
+ app/main.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/app/main.cpp b/app/main.cpp
+index 0494b5f..8aab4c6 100644
+--- a/app/main.cpp
++++ b/app/main.cpp
+@@ -53,13 +53,13 @@ int main(int argc, char *argv[])
+ //
+
+ std::string pipeline_str = \
+- "rtpbin name=rtpbin udpsrc caps=\"application/x-rtp,media=(string)video,clock-rate=(int)90000,encoding-name=JPEG,payload=26\" port=5005 ! rtpbin.recv_rtp_sink_0 rtpbin. ! rtpjpegdepay ! jpegdec ! ";
++ "udpsrc caps=\"application/x-rtp,media=(string)video,clock-rate=(int)90000,encoding-name=H264,payload=96\" port=5005 ! rtph264depay ! video/x-h264, stream-format=byte-stream,alignment=au ! h264parse ! omxh264dec ! ";
+ GstPlugin *plugin = gst_registry_find_plugin(gst_registry_get (), "vaapisink");
+ if(plugin) {
+ pipeline_str += "vaapisink";
+ gst_object_unref(plugin);
+ } else {
+- pipeline_str += "waylandsink";
++ pipeline_str += " waylandsink";
+ }
+ #ifdef DEBUG
+ std::cout << "Using pipeline: " << pipeline_str << std::endl;
+--
+2.7.4
+
diff --git a/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bbappend b/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bbappend
new file mode 100644
index 0000000..bfbb524
--- /dev/null
+++ b/recipes-demo-hmi/cluster-receiver/cluster-receiver_git.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " \
+ file://0001-Update-omxh264dec-parameter.patch \
+"