aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhou Mingying <zhoumy@cn.fujitsu.com>2019-08-20 15:21:03 +0800
committerZhou Mingying <zhoumy@cn.fujitsu.com>2019-08-23 11:11:37 +0800
commitaa6910c87ec4232588593428e98d8903b4c516bf (patch)
treea7d1bc8314fe51c9991c6f6609ebc727b0621dab
parent1a1f700db9f370e4d4f2fc45e9155cd190726d68 (diff)
refactor packagegroup-agl-cluster-demo-qtcompositor.bb to make some common pieces
Create the below file in recipes-platform/packagegroups packagegroup-agl-networking.bb packagegroup-agl-source-han-sans-ttf-fonts.bb packagegroup-agl-ttf-fonts.bb Modify the below bb files to include the new packagegroups packagegroup-agl-cluster-demo-platform.bb packagegroup-agl-cluster-demo-qtcompositor.bb Bug-AGL: SPEC-2731 Signed-off-by: Zhou Mingying <zhoumy@cn.fujitsu.com> Signed-off-by: Liu Wenlong <liuwl.fnst@cn.fujitsu.com> Change-Id: I422a45ec7d51df2f8621e3297f60383ceb8d69c1
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb20
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb16
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-networking.bb23
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb20
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb21
5 files changed, 69 insertions, 31 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
index d639495..3b0c91c 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
@@ -13,18 +13,11 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
packagegroup-agl-profile-cluster-qt5 \
+ packagegroup-agl-ttf-fonts \
+ packagegroup-agl-source-han-sans-ttf-fonts \
+ packagegroup-agl-networking \
"
-# fonts
-TTF_FONTS = " \
- ttf-bitstream-vera \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
- ttf-dejavu-serif \
- source-han-sans-cn-fonts \
- source-han-sans-jp-fonts \
- source-han-sans-tw-fonts \
- "
AGL_APPS = " \
cluster-dashboard \
@@ -41,13 +34,6 @@ RDEPENDS_${PN}_append = " \
hmi-debug \
libva-utils \
linux-firmware-ralink \
- connman \
- connman-client \
- connman-tools \
- cluster-connman-conf \
- iproute2 \
- dhcp-client \
- ${TTF_FONTS} \
${AGL_APPS} \
${AGL_APIS} \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb
index 879248c..cc034d3 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb
@@ -13,6 +13,8 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
packagegroup-agl-profile-cluster-qtcompositor \
+ packagegroup-agl-ttf-fonts \
+ packagegroup-agl-networking \
"
AGL_SERVICE = " \
@@ -30,13 +32,6 @@ AGL_SERVICE = " \
SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
'sdl-core', '', d)}"
-# fonts
-TTF_FONTS = " \
- ttf-bitstream-vera \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
- ttf-dejavu-serif \
- "
AGL_APPS = " \
cluster-gauges-qtcompositor \
@@ -45,15 +40,8 @@ AGL_APPS = " \
RDEPENDS_${PN}_append = " \
libva-utils \
linux-firmware-ralink \
- connman \
- connman-client \
- connman-tools \
- cluster-connman-conf \
- iproute2 \
- dhcp-client \
can-utils \
most \
- ${TTF_FONTS} \
${AGL_SERVICE} \
${AGL_APPS} \
${SMARTDEVICELINK} \
diff --git a/recipes-platform/packagegroups/packagegroup-agl-networking.bb b/recipes-platform/packagegroups/packagegroup-agl-networking.bb
new file mode 100644
index 0000000..3e89303
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-networking.bb
@@ -0,0 +1,23 @@
+SUMMARY = "The networking for AGL"
+DESCRIPTION = "A set of packages for AGL cluster's networking"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-networking \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+# fonts
+RDEPENDS_${PN}_append = " \
+ connman \
+ connman-client \
+ connman-tools \
+ cluster-connman-conf \
+ iproute2 \
+ dhcp-client \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb b/recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb
new file mode 100644
index 0000000..fb33289
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The Source Han Sans ttf fonts for AGL"
+DESCRIPTION = "A set of packages for source Han Sans ttf fonts"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-source-han-sans-ttf-fonts \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+# fonts
+RDEPENDS_${PN}_append = " \
+ source-han-sans-cn-fonts \
+ source-han-sans-jp-fonts \
+ source-han-sans-tw-fonts \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb b/recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb
new file mode 100644
index 0000000..9a3b578
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb
@@ -0,0 +1,21 @@
+SUMMARY = "The ttf fonts for AGL"
+DESCRIPTION = "A set of packages for fonts"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ttf-fonts \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+# fonts
+RDEPENDS_${PN}_append = " \
+ ttf-bitstream-vera \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+ ttf-dejavu-serif \
+"