summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-08-02 12:44:53 +0200
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-08-26 10:20:10 +0200
commit1ac37e2eba577a86bdc607b1ac44e781f0005073 (patch)
tree4bb6fdd6be61b36d2120d10c4c61f7d839363098
parent130798b869fc81db7c48f515f1df7867ca591b4a (diff)
html5-launcher: create recipe
This recipe makes use of npm to install the JS dependencies and also generate the wgt file. Bug-AGL: SPEC-2401 Change-Id: I97557fa9193edabff611f98d12e54ec2463d4415 Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
-rw-r--r--recipes-demo-hmi/html5-launcher/html5-launcher_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb b/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
new file mode 100644
index 00000000..ce8a1d11
--- /dev/null
+++ b/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Launcher Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-launcher/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}