summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-07-06 17:35:09 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-07 17:51:05 +0000
commit1f81a10af3d8c201d495fddc99a663595b6b89fa (patch)
tree287b1fcb88e56d23d22f4432404faaf4b149dc6e
parent4ce3f8ae423f01ac3cc3bd20a886146f8c8a9bf6 (diff)
Remove old radio plugins
The radio functionality is now contained in the binding, remove the unused QtMultimedia plugins. Change-Id: I262f63af646b92a6f04ecf238274b5137e9fbf41 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-qt/qml-radio-plugin/qml-radio-plugin_0.2.bb47
-rw-r--r--recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb21
2 files changed, 0 insertions, 68 deletions
diff --git a/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.2.bb b/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.2.bb
deleted file mode 100644
index f9e1c630..00000000
--- a/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.2.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-SUMMARY = "AM/FM Radio QML plugin (for RTL2832U hardware)"
-DESCRIPTION = "This provides a simple QML plugin able to detect and use \
-radio hardware, most notably RTL2832U chipsets (although it can easily \
-be extended). Among other things, it provides generic APIs to display \
-status, switch between AM/FM mode, choose frequency, mute sound..."
-HOMEPAGE = "https://github.com/iotbzh/qml_radio_plugin"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://qml_radio.cpp;endline=16;md5=10a65c128e3a6cff2a61bb38556ceb04"
-
-DEPENDS = "qtbase-native qtdeclarative rtl-sdr pulseaudio alsa-lib"
-RDEPENDS_${PN}-examples = "qtdeclarative-tools qtquickcontrols-qmlplugins"
-
-SRC_URI = "git://github.com/iotbzh/qml_radio_plugin"
-SRCREV = "36e6bbaaa6637abab344d38d8a0c4794fa42fb03"
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
-
-QML_LIBDIR = "${libdir}/qt5/qml"
-
-do_configure_append() {
- # when building with "security_flags.inc", libtool thinks that
- # "-pie" means we want an executable, and links with related C
- # runtime objects. Work around this until libtool is fixed.
- sed -i 's/".\+Scrt1.o/"/g' ${B}/*libtool
- sed -i 's/ .\+Scrt1.o/ /g' ${B}/*libtool
- sed -i 's/-lgcc / /g' ${B}/*libtool
- sed -i 's/-lgcc"/"/g' ${B}/*libtool
-}
-
-do_install_append() {
- # Remove .la files for loadable module
- rm -f ${D}/${QML_LIBDIR}/radio/*.la
- # Install QML example
- install -d ${D}/${datadir}/qt5/examples/radio
- install -m 0644 ${S}/radio.qml ${D}/${datadir}/qt5/examples/radio
-}
-
-PACKAGES += "${PN}-examples"
-
-FILES_${PN} += "${QML_LIBDIR}/radio/*.so ${QML_LIBDIR}/radio/qmldir"
-FILES_${PN}-dbg += "${QML_LIBDIR}/radio/.debug"
-FILES_${PN}-examples += "${datadir}"
diff --git a/recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb b/recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb
deleted file mode 100644
index 98ba6396..00000000
--- a/recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "QtMultimedia RTL-SDR Radio Plugin"
-DESCRIPTION = "QtMultimedia RTL-SDR Radio Plugin"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/staging/qtmultimedia-rtlfm-radio-plugin"
-LICENSE = "MPL-2.0 & GPLv2+"
-LIC_FILES_CHKSUM = "file://rtlfmradioplugin.cpp;endline=5;md5=747a800420eac5cb6ab2cb85514d88b2 \
- file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-
-DEPENDS = "qtmultimedia pulseaudio alsa-lib rtl-sdr"
-
-PV = "0.1+git${SRCPV}"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/qtmultimedia-rtlfm-radio-plugin;protocol=https"
-SRCREV = "${AUTOREV}"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5
-
-FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/mediaservice/*.so"
-FILES_${PN}-dbg += "${OE_QMAKE_PATH_PLUGINS}/mediaservice/.debug"
-