summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-03 16:05:25 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 14:56:43 +0000
commit37ef25bb36711114fd379e74ab18737e0224c364 (patch)
treeaa792c97d126b52040b9f80b3e27a416025e58dd
parentfe36156821cea7b32a5ae439c9e0a166a65c4068 (diff)
html5-homescreen: create recipe and add to html5 demo
Bug-AGL: SPEC-2401 Change-Id: I6bcc182f856fa56d76152e28a0ee96d74ff7b555 Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
-rw-r--r--recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb25
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
new file mode 100644
index 00000000..68956263
--- /dev/null
+++ b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Homescreen Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-homescreen/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index cddab0ba..b739039e 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -18,6 +18,7 @@ RDEPENDS_${PN} += "\
"
AGL_APPS = " \
+ html5-homescreen \
html5-launcher \
html5-hvac \
html5-settings \