summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-02-18 17:30:13 -0500
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-04-09 18:27:07 +0200
commit5f5a1fb6ea4fd884040ef3175f478321651afeab (patch)
treec9475e809bd513770945a6481f0b0cd7dc548fc4
parent16224041eeeee070fd40a14d457adb5fc9d7ae8e (diff)
Upgrade to thud
Changes include: - Add LAYERSERIES_COMPAT definition to layer.conf - Replace libvcard recipe with bbappend now that a recipe is available in meta-qt5 - Add OECMAKE_GENERATOR = "Unix Makefiles" to libnaviapi-agl recipe for now to work around CMake+ninja issue - Add patch to navigation app to fix compilation against OpenSSL 1.1 - Remove libssp-dev from agl-demo-platform-crosssdk, upstream have removed it from non-mingw32 platform SDKs Known issues: - CMake+ninja issue in cmake-apps-module has been worked around with OECMAKE_GENERATOR Bug-AGL: SPEC-1837 Change-Id: I14c5355fb38d5eed064f154f889d61d8e46854b7 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-connectivity/libvcard/libvcard_%.bbappend3
-rw-r--r--recipes-connectivity/libvcard/libvcard_git.bb17
-rwxr-xr-xrecipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb2
-rw-r--r--recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch31
-rwxr-xr-xrecipes-demo-hmi/navigation/navigation_git.bb1
-rwxr-xr-xrecipes-platform/images/agl-demo-platform-crosssdk.bb1
7 files changed, 39 insertions, 18 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 0047d613..43a5be76 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "agl-demo"
BBFILE_PATTERN_agl-demo = "^${LAYERDIR}/"
BBFILE_PRIORITY_agl-demo = "7"
+
+LAYERSERIES_COMPAT_agl-demo = "thud"
diff --git a/recipes-connectivity/libvcard/libvcard_%.bbappend b/recipes-connectivity/libvcard/libvcard_%.bbappend
new file mode 100644
index 00000000..6761a0ff
--- /dev/null
+++ b/recipes-connectivity/libvcard/libvcard_%.bbappend
@@ -0,0 +1,3 @@
+SRCREV = "9b43ca01865f171cdd8a7d47b6da7c1a41c03e38"
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-connectivity/libvcard/libvcard_git.bb b/recipes-connectivity/libvcard/libvcard_git.bb
deleted file mode 100644
index 86e3c0f1..00000000
--- a/recipes-connectivity/libvcard/libvcard_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "Qt vCard library"
-SECTION = "libs"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f94eaed54ffa1718d593504bae740faf"
-
-DEPENDS += "qtbase"
-
-SRCREV = "9b43ca01865f171cdd8a7d47b6da7c1a41c03e38"
-SRC_URI = "git://github.com/pol51/libvcard.git;protocol=https"
-
-PV = "1.0+gitr${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-inherit cmake_qt5
-
-ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb b/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
index af528ff6..e4dc8440 100755
--- a/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
+++ b/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
@@ -14,3 +14,5 @@ SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch
SRCREV = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
S = "${WORKDIR}/git"
+# FIXME: Remove once CMake+ninja issues are resolved
+OECMAKE_GENERATOR = "Unix Makefiles"
diff --git a/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch b/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch
new file mode 100644
index 00000000..9506ce11
--- /dev/null
+++ b/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch
@@ -0,0 +1,31 @@
+gpsnavi: Fix compilation with OpenSSL 1.1
+
+Handle the ERR_load_crypto_strings and ERR_free_strings functions no
+longer being present in OpenSSL 1.1.
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
+index eadab8f..2dfe1f3 100755
+--- a/src/sms/sms-core/SMCAL/SMCAL.c
++++ b/src/sms/sms-core/SMCAL/SMCAL.c
+@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
+ // 初期化
+ ERR_load_BIO_strings();
+ SSL_load_error_strings();
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ ERR_load_crypto_strings();
++#endif
+ OpenSSL_add_all_algorithms();
+
+ // SSLの初期化(戻り値は常に1)
+@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
+ if (NULL != cal->ssl.ctx) {
+ SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);
+ }
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ ERR_free_strings();
++#endif
+
+ cal->ssl.ssl = NULL;
+ cal->ssl.ctx = NULL;
diff --git a/recipes-demo-hmi/navigation/navigation_git.bb b/recipes-demo-hmi/navigation/navigation_git.bb
index 3ad00b25..b5eeb890 100755
--- a/recipes-demo-hmi/navigation/navigation_git.bb
+++ b/recipes-demo-hmi/navigation/navigation_git.bb
@@ -21,6 +21,7 @@ RDEPENDS_${PN} += " agl-service-navigation "
SRCREV="5048c2e234febeb20df0b193e1bf1ac50f3896a5"
SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
file://0001-add-4A-playback-support.patch \
+ file://0002-openssl-1.1-fixes.patch \
file://download_mapdata_jp.sh \
file://download_mapdata_uk.sh \
file://org.agl.naviapi.conf \
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index bce2e6a8..2812aec9 100755
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -42,7 +42,6 @@ TOOLCHAIN_TARGET_TASK += " \
libexif-dev \
pango-dev \
libdrm-dev \
- libssp-dev \
lua-dev \
lua-staticdev \
libafb-helpers-staticdev \