summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-10-12 16:58:07 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-12 21:55:18 +0000
commit601ba51b28e533c525cfa34e5b3838ec732410cc (patch)
tree57ab219032186e9f5935899687aafe3c58efb228
parent4fd6eb328820d7f6657c223bf1b1a19e8c864a03 (diff)
Add switch between homescreen and homescreen-2017
Add option to switch between homescreen implementations. Default is the 'old' homescreen. Only if DISTRO_FEATURES += " agl-hmi-framework " is set we switch to use the new packagegroup(s) for homescreen-2017. This setting is done when you call aglsetup.sh with the 'agl-hmi-framework' feature enabled. Change-Id: Ieb45c1534f0759e8adb891f77ae85cb917e736e2 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
index dd397fce..cc93ddaa 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -14,9 +14,14 @@ ALLOW_EMPTY_${PN} = "1"
SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
'packagegroup-agl-smartdevicelink', '', d)}"
+# old homescreen package
+HOMESCREEN-OLD = "homescreen"
+# packages from hmi-framework aka homescreen-2017
+HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
+
RDEPENDS_${PN} += "\
packagegroup-agl-appfw \
- homescreen \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
udisks \
${SMARTDEVICELINK} \
"