summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>2019-03-08 16:03:37 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-03-15 15:07:53 +0000
commit61603255c139216149f71a63426e2bdffc819609 (patch)
tree405488c1ea588a0db348166921f695d638062460
parent21096b5b383365e2877dc485611eca1c84b968a9 (diff)
Add onscreenapp recipe
Onscreenapp is a qt application for showing onscreens. Applications can show/hide onscreen by calling homescreen-service's showWindow/hideWindow verb. Applications also can customize onscreen's title,type, display contents and buttons. Some images about onscreen pattern had uploaded in JIRA SPEC-1967. Bug-AGL: SPEC-1967 Change-Id: Ica1b5912e109d39eb6743144cfc523dbf64cac9f Signed-off-by: wang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>
-rw-r--r--recipes-demo-hmi/onscreenapp/onscreenapp_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb b/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
new file mode 100644
index 00000000..ae905ea6
--- /dev/null
+++ b/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "onscreenapp for displaying onscreen"
+DESCRIPTION = "AGL HMI Application for displaying onscreen"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/onscreenapp"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/onscreenapp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen libwindowmanager qlibwindowmanager"
+
+inherit qmake5 aglwgt