summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-20 17:58:48 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-20 17:58:48 -0500
commit82744513c902f09a7e58695fa013a51aa9713784 (patch)
tree53d8684d2a49c9954c568bfe426ce69d8781cf07
parentb0620c288705d14aadb9cdd95e47b8b22dc7662a (diff)
alexa-viewer: add recipe and conditionally add to demo imagehalibut_8.0.6halibut_8.0.5halibut/8.0.6halibut/8.0.58.0.68.0.5
Add recipe for demo voice capabilities GUI metadata event viewer for Alexa voiceagent, and conditionally add it to the list of applications in packagegroup-agl-demo-platform based on the agl-voiceagent-alexa feature being present in IMAGE_FEATURES. Bug-AGL: SPEC-3110 Change-Id: I7b84ace51430937dbcb35f4773b06290039a19bd Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb33
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
new file mode 100644
index 00000000..f98704ee
--- /dev/null
+++ b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Demo voice capabilities template viewer for Alexa voiceagent"
+DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+ qtquickcontrols2 \
+ qlibwindowmanager \
+ qlibhomescreen \
+ af-binder \
+ libqtappfw \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} = " \
+ libqtappfw \
+ libafbwsc \
+ qlibwindowmanager \
+ qlibhomescreen \
+ agl-service-voice-high-capabilities \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 05081683..eaa674d9 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -59,6 +59,7 @@ AGL_APPS = " \
agl-service-signal-composer \
low-can-demo \
virtual/mixer \
+ ${@bb.utils.contains('IMAGE_FEATURES', 'agl-voiceagent-alexa', 'alexa-viewer' , '', d)} \
"
QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"