summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-09-09 19:54:08 -0400
committerScott Murray <scott.murray@konsulko.com>2019-09-09 19:56:34 -0400
commit8c8455f86f6ee8e9a40d163b260b60aea250b297 (patch)
tree5ec102e1c717e8ed2866a315dab67a105e6af0ac
parent3cc80df78623edf03f7b203ff47828f77e5cf4cd (diff)
Migrate poiapp and libnaviapi-agl to AGL Gerrit
Update the poiapp and libnaviapi-agl recipes to point at AGL Gerrit for their source repositories. Additionally, the libnaviapi-agl recipe has been moved to recipes-demo/navigation since being beside its users seems to be a more logical location, and a few lines have been reordered in the poiapp recipe to better match the OpenEmbedded style guide. Bug-AGL: SPEC-2787 Change-Id: I41334b47b4970adb51fc943368dba7e07bbf113d Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--[-rwxr-xr-x]recipes-demo-hmi/navigation/libnaviapi-agl_git.bb (renamed from recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb)4
-rw-r--r--recipes-demo-hmi/navigation/poiapp_git.bb19
2 files changed, 9 insertions, 14 deletions
diff --git a/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb b/recipes-demo-hmi/navigation/libnaviapi-agl_git.bb
index e4dc8440..87087e1a 100755..100644
--- a/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
+++ b/recipes-demo-hmi/navigation/libnaviapi-agl_git.bb
@@ -10,8 +10,8 @@ DEPENDS = "af-binder json-c libdbus-c++ af-main-native"
inherit cmake
-SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
-SRCREV = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-navigation;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
# FIXME: Remove once CMake+ninja issues are resolved
diff --git a/recipes-demo-hmi/navigation/poiapp_git.bb b/recipes-demo-hmi/navigation/poiapp_git.bb
index 9c9292b0..87263e10 100644
--- a/recipes-demo-hmi/navigation/poiapp_git.bb
+++ b/recipes-demo-hmi/navigation/poiapp_git.bb
@@ -6,20 +6,15 @@ SECTION = "apps"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
-inherit cmake_qt5 pkgconfig
-inherit aglwgt
-
-DEPENDS += " qtbase json-c libnaviapi-agl \
- af-binder qlibwindowmanager libhomescreen \
+DEPENDS += "qtbase json-c libnaviapi-agl \
+ qlibwindowmanager libhomescreen \
"
-RDEPENDS_${PN} = " qtbase \
- "
-
-SRCREV = "c2691cb265d9198542482a860f1df378e8c2708b"
-SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
- file://0001-add-display-permission.patch \
- "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} = "qtbase"