summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-06-09 11:27:04 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-12 08:34:59 +0000
commita22fe6936f2256b4e8f23d6f7e2494b8e6ac7a65 (patch)
tree015b0559d8bf004417c3b1360641cb9d65b62938
parent13abc8463dbacc672769f66f27d926cc13524d97 (diff)
fix MOST driver dependency issues
This patch adds a new "most" receipe for building the MOST driver. The receipe replaces the old ones, as it builds all modules at once. Hence, the receipes aim*, hdm* and mostcore are removed. Additionally, the *.bb file for the demo platform is modified to reflect these changes. This patch is needed to avoid dependency issues among the modules of the driver stack. Although, the problem has been reported with SPEC 438 and a patch set to fix it has been introduced with Change #8447, it is still present on RaspberryPi. Change-Id: Id6104ee6d9bf1b7d9744761a6529461176fdd8b2 Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
-rw-r--r--recipes-kernel/aim-cdev/aim-cdev.bb24
-rw-r--r--recipes-kernel/aim-network/aim-network.bb25
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb25
-rw-r--r--recipes-kernel/aim-v4l2/aim-v4l2.bb24
-rw-r--r--recipes-kernel/hdm-dim2/hdm-dim2.bb24
-rw-r--r--recipes-kernel/hdm-i2c/hdm-i2c.bb24
-rw-r--r--recipes-kernel/hdm-usb/hdm-usb.bb24
-rw-r--r--recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch (renamed from recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch)6
-rw-r--r--recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch (renamed from recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch)6
-rw-r--r--recipes-kernel/most/most.bb32
-rw-r--r--recipes-kernel/mostcore/mostcore.bb23
-rwxr-xr-xrecipes-platform/packagegroups/packagegroup-agl-demo-platform.bb9
12 files changed, 39 insertions, 207 deletions
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
deleted file mode 100644
index e8c101e9..00000000
--- a/recipes-kernel/aim-cdev/aim-cdev.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build character device driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
- fi
-}
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
deleted file mode 100644
index 7ef192ce..00000000
--- a/recipes-kernel/aim-network/aim-network.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Build networking driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-SRC_URI_append_porter = " file://0001-aim-network-backport-patch-for-3.10.31-ltsi.patch"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
- fi
-}
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
deleted file mode 100644
index cb2b9836..00000000
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Build ALSA driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-SRC_URI_append_porter = " file://0001-aim-sound-3.10.31-ltsi-backport.patch"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
- fi
-}
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
deleted file mode 100644
index 5233eed9..00000000
--- a/recipes-kernel/aim-v4l2/aim-v4l2.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build V4L2 driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
- fi
-}
diff --git a/recipes-kernel/hdm-dim2/hdm-dim2.bb b/recipes-kernel/hdm-dim2/hdm-dim2.bb
deleted file mode 100644
index a9179299..00000000
--- a/recipes-kernel/hdm-dim2/hdm-dim2.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build DIM2 adapter driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
- fi
-}
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
deleted file mode 100644
index 90216ec2..00000000
--- a/recipes-kernel/hdm-i2c/hdm-i2c.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build I2C adapter driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
- fi
-}
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
deleted file mode 100644
index df45e370..00000000
--- a/recipes-kernel/hdm-usb/hdm-usb.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build USB adapter driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
- fi
-}
diff --git a/recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch b/recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch
index 41728c2d..d0bbd72e 100644
--- a/recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch
+++ b/recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch
@@ -8,10 +8,10 @@ Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
aim-network/networking.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
-diff --git a/networking.c b/aim-network/networking.c
+diff --git a/aim-network/networking.c b/aim-network/networking.c
index ce1764c..e04b523 100644
---- a/networking.c
-+++ b/networking.c
+--- a/aim-network/networking.c
++++ b/aim-network/networking.c
@@ -362,8 +362,7 @@ static int aim_probe_channel(struct most_interface *iface, int channel_idx,
if (nd->tx.linked || nd->rx.linked) {
diff --git a/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch b/recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch
index b999b0d6..31e9400d 100644
--- a/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch
+++ b/recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch
@@ -11,10 +11,10 @@ Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
aim-sound/sound.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/sound.c b/aim-sound/sound.c
+diff --git a/aim-sound/sound.c b/aim-sound/sound.c
index 3dc625c..af0af2d 100644
---- a/sound.c
-+++ b/sound.c
+--- a/aim-sound/sound.c
++++ b/aim-sound/sound.c
@@ -595,7 +595,7 @@ static int audio_probe_channel(struct most_interface *iface, int channel_id,
return ret;
}
diff --git a/recipes-kernel/most/most.bb b/recipes-kernel/most/most.bb
new file mode 100644
index 00000000..512610af
--- /dev/null
+++ b/recipes-kernel/most/most.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Build MOST driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+inherit module
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-network-3.10.31-ltsi-backport.patch \
+ file://0001-aim-sound-3.10.31-ltsi-backport.patch \
+ "
+S = "${WORKDIR}/git/driver"
+SRCREV = "${AUTOREV}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
+ echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
+ echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
+ echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
+ echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
+ echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
+ echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
+ echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
+ fi
+}
diff --git a/recipes-kernel/mostcore/mostcore.bb b/recipes-kernel/mostcore/mostcore.bb
deleted file mode 100644
index 35865ce4..00000000
--- a/recipes-kernel/mostcore/mostcore.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Build MOST core driver"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
- fi
-}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 1ad6f2c8..1df09f03 100755
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -21,15 +21,8 @@ RDEPENDS_${PN} += "\
MOST_DRIVERS = " "
MOST_DRIVERS_append = " \
- aim-cdev \
- aim-network \
- aim-sound \
- aim-v4l2 \
- hdm-dim2 \
- hdm-i2c \
- hdm-usb \
mocca-usb \
- mostcore \
+ most \
"
# HVAC dependencies depend on drivers above