summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2017-04-01 23:35:18 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-05 07:13:20 +0000
commitaaaf066b624dfa5fc84d3047061b76aab1b5ca39 (patch)
tree9831d1916d50dcd1c5de4af93ccca7436b0222d6
parent2375a927831fd8328f45badacb42ee10cc12d3f0 (diff)
Correspondence of AGL-wgt for poi app
POI app makefile supported the 'make package' target. This patch will change to the corresponding git revision. Bug-AGL: SPEC-384 Change-Id: I3fda01580e80ae60db7386b19cef31e5d71038cf Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rw-r--r--recipes-demo-hmi/navigation/poiapp/config.xml12
-rwxr-xr-xrecipes-demo-hmi/navigation/poiapp_git.bb18
2 files changed, 4 insertions, 26 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp/config.xml b/recipes-demo-hmi/navigation/poiapp/config.xml
deleted file mode 100644
index 2f387db6..00000000
--- a/recipes-demo-hmi/navigation/poiapp/config.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<widget xmlns="http://www.w3.org/ns/widgets" id="poi" version="0.1">
- <name>POI</name>
- <icon src="poi.png"/>
- <content src="poi" type="application/x-executable"/>
- <description>POI App</description>
- <author>AISIN AW</author>
- <feature name="urn:AGL:required-permission">
- <param name="http://tizen.org/privilege/internal/dbus" value="required" />
- </feature>
- <license>GPL</license>
-</widget>
diff --git a/recipes-demo-hmi/navigation/poiapp_git.bb b/recipes-demo-hmi/navigation/poiapp_git.bb
index 3bdac9ea..7e608074 100755
--- a/recipes-demo-hmi/navigation/poiapp_git.bb
+++ b/recipes-demo-hmi/navigation/poiapp_git.bb
@@ -9,22 +9,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
inherit cmake_qt5 pkgconfig
inherit aglwgt
-DEPENDS += " qtbase libdbus-c++ json-c zip-native \
+DEPENDS += " qtbase libdbus-c++ json-c \
"
-SRCREV="3e162a60c76dee1b4dede81db55e0fa6bae05433"
-SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
- file://config.xml \
-"
+SRCREV = "b0e059007de776450c91c983a2bcac20414617e9"
+SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
+ "
S = "${WORKDIR}/git"
-do_install_append() {
- mkdir -p ${WORKDIR}/widget
- install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
- install -m 0755 ${D}/usr/bin/yelp-client ${WORKDIR}/widget/poi
-
- mkdir -p ${B}/package
- zip -ju ${B}/package/poi.wgt ${WORKDIR}/widget/poi ${WORKDIR}/widget/config.xml
-
-}