summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-08-20 03:33:02 +0300
committerMatt Ranostay <matt.ranostay@konsulko.com>2019-08-29 02:39:52 +0300
commitc0a8b9e819a2ca473aabb91feac9833f0397e8c3 (patch)
tree8bb756c30ab5a9f09a27ddbe9fa067b517f80e96
parent115d102b54c8a5b1a4545e5f3f46a23210bdb1d0 (diff)
graphics: add noto-emoji git recipe
Add color emoji support to AGL via the noto-emoji font. Bug-AGL: SPEC-2701 Change-Id: Idf21d5c3f8ac2fe0fe25945b6dca1d8956fb7f7b Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-graphics/noto-emoji/noto-emoji_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-graphics/noto-emoji/noto-emoji_git.bb b/recipes-graphics/noto-emoji/noto-emoji_git.bb
new file mode 100644
index 00000000..416f568f
--- /dev/null
+++ b/recipes-graphics/noto-emoji/noto-emoji_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Google noto emoji font pack"
+HOMEPAGE = "https://github.com/googlefonts/noto-emoji"
+SECTION = "fonts"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://github.com/googlefonts/noto-emoji;protocol=https;branch=master"
+SRCREV = "833a43d03246a9325e748a2d783006454d76ff66"
+
+RDEPENDS_${PN} = "fontconfig"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -m 0755 -d ${D}/${datadir}/fonts/ttf
+ install -m 0644 -p ${S}/NotoColorEmoji.ttf ${D}/${datadir}/fonts/ttf
+}
+
+FILES_${PN} += "${datadir}/fonts/ttf/NotoColorEmoji.ttf"
+
+inherit allarch fontcache
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"