summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-06 17:03:34 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-11 21:51:34 +0000
commitc650bb7c454ba8d222fd13f9fd4810dc07e59dd3 (patch)
tree262a411cd79e5a10037eb564a3589102c347d8a8
parentacc9b3c6ed77dd21f507ca410c7fe7a2c8087e39 (diff)
Remove qtaglextras and its dependencies libhomescreen and agl-service-homescreen, as they have been moved to the meta-agl-profile-graphical-qt5 and meta-agl-profile-graphical layers in meta-agl. This is required to fix building the cluster demo SDK now that qtaglextras has been added to packagegroup-qt5-toolchain-target. These changes are a partial backport of the move of the contents of meta-hmi-framework in master / Halibut. Bug-AGL: SPEC-2484 Change-Id: I057c863a4fd2c87d419c18b114a6c4473c4d75c3 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb14
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf16
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen_git.bb26
-rw-r--r--recipes-demo-hmi/qtaglextras/qtaglextras_git.bb28
4 files changed, 0 insertions, 84 deletions
diff --git a/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb b/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
deleted file mode 100644
index b56f47c4..00000000
--- a/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Homescreen binding and client library for application"
-DESCRIPTION = "agl-service-homescreen is the binding library"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen"
-SECTION = "HMI"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "dbus glib-2.0 af-binder json-c"
-
-inherit cmake aglwgt
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "b730d31a7e5e23756ab1b076de21d41369a500c5"
-S = "${WORKDIR}/git"
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf b/recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf
deleted file mode 100644
index dc3852ee..00000000
--- a/recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf
+++ /dev/null
@@ -1,16 +0,0 @@
-<!DOCTYPE busconfig PUBLIC
-"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
-"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy context="default">
- <!-- Allow everyone to talk to main service. We'll later add an agent to
- only share the location if user allows it. -->
- <allow send_interface="org.agl.statusbar"/>
- </policy>
-
- <policy user="root">
- <!-- Allow root to own the name on the bus -->
- <allow own="org.agl.statusbar"/>
- </policy>
-</busconfig>
-
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
deleted file mode 100644
index 1c9a38ca..00000000
--- a/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "AGL Home Screen Library"
-DESCRIPTION = "libhomescreen"
-HOMEPAGE = "http://docs.automotivelinux.org"
-LICENSE = "Apache-2.0"
-SECTION = "libs"
-
-BBCLASSEXTEND = " nativesdk"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "af-binder json-c"
-
-inherit cmake
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
- file://org.agl.statusbar.conf \
- "
-SRCREV = "d01f3c61041ff7b8d2d942f99680407ee10320bc"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- mkdir -p ${D}${sysconfdir}/dbus-1/session.d
- install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
-}
-
-RDEPENDS_${PN} = "agl-service-homescreen"
diff --git a/recipes-demo-hmi/qtaglextras/qtaglextras_git.bb b/recipes-demo-hmi/qtaglextras/qtaglextras_git.bb
deleted file mode 100644
index a874a9cf..00000000
--- a/recipes-demo-hmi/qtaglextras/qtaglextras_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-DEPENDS += "qtbase qtdeclarative qtquickcontrols2 qlibwindowmanager libhomescreen"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtaglextras;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "2fe96de41a540477d425403cf3a59ec6f5871521"
-
-PV = "5.8.0+git${SRCPV}"
-S = "${WORKDIR}/git/"
-
-inherit qmake5
-
-PACKAGES += "${PN}-mkspecs"
-
-FILES_${PN}-mkspecs = "\
- ${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs \
-"
-
-FILES_${PN}-dev += " \
- ${OE_QMAKE_PATH_LIBS}/lib*${SOLIBSDEV} \
- ${OE_QMAKE_PATH_LIBS}/pkgconfig \
- ${OE_QMAKE_PATH_LIBS}/cmake/* \
- ${OE_QMAKE_PATH_LIBS}/*.prl \
- ${OE_QMAKE_PATH_LIBS}/*.la \
- ${OE_QMAKE_PATH_DATA}/* \
- ${OE_QMAKE_PATH_HEADERS}/* \
-"