summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-26 21:01:11 -0400
committerScott Murray <scott.murray@konsulko.com>2019-06-26 21:02:45 -0400
commitd61b4d3a028d7abc74cbcb9bad4cf1d21eb3f087 (patch)
tree62324988bb48311a676e69d52ca969861a1eb7d4
parent2cba019cdfc24b49be57ee53e136d5fb7bf2af10 (diff)
ondemandnavi-config: switch to allarch class
Switch from setting PACKAGE_ARCH to inheriting the allarch class in the ondemandnavi-config recipe. This fixes a failure when building an image with the ondemandnavi application that seems due to a change between rocko and thud. Bug-AGL: SPEC-2576 Change-Id: I5c99571db72e600ae0da05304e46c503466985d2 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--[-rwxr-xr-x]recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb b/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb
index 784341ed..212971f2 100755..100644
--- a/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb
+++ b/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb
@@ -9,17 +9,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2
SRC_URI = "file://naviconfig.ini \
"
-S = "${WORKDIR}"
+inherit allarch
MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
+do_compile[noexec] = "1"
+
do_install () {
- install -d ${D}${sysconfdir}
- install -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}
+ install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
}
-
-PACKAGE_ARCH = "all"
-
-PACKAGES = "${PN}"
-FILES_${PN} = "/etc/naviconfig.ini"