summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-11-12 07:09:57 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-19 16:41:30 +0000
commitd713285f617aed53a897da8d9f8f66943c7b09e4 (patch)
tree0fa3c06d3f3d1419e17c9e823c9b5c2cce6c91dc
parent94d43cc23ef59dcce4912323e19c31247126c101 (diff)
mapviewer: remove recipe due to package being deprecated
mapviewer is no longer used, and will not work with agl-service-navigation rewrite so must be removed. Bug-AGL: SPEC-2880 Change-Id: Ia3a60200ba78be689874c99b18c2b5b329c39a45 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch31
-rw-r--r--recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh23
-rw-r--r--recipes-demo-hmi/navigation/mapviewer/mapviewer.service22
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend25
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_git.bb28
5 files changed, 0 insertions, 129 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch b/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
deleted file mode 100644
index 9506ce11..00000000
--- a/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-gpsnavi: Fix compilation with OpenSSL 1.1
-
-Handle the ERR_load_crypto_strings and ERR_free_strings functions no
-longer being present in OpenSSL 1.1.
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
-index eadab8f..2dfe1f3 100755
---- a/src/sms/sms-core/SMCAL/SMCAL.c
-+++ b/src/sms/sms-core/SMCAL/SMCAL.c
-@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
- // 初期化
- ERR_load_BIO_strings();
- SSL_load_error_strings();
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- ERR_load_crypto_strings();
-+#endif
- OpenSSL_add_all_algorithms();
-
- // SSLの初期化(戻り値は常に1)
-@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
- if (NULL != cal->ssl.ctx) {
- SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);
- }
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- ERR_free_strings();
-+#endif
-
- cal->ssl.ssl = NULL;
- cal->ssl.ctx = NULL;
diff --git a/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh b/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh
deleted file mode 100644
index 0d7bf205..00000000
--- a/recipes-demo-hmi/navigation/mapviewer/mapviewer-settings.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-LMC=/usr/bin/LayerManagerControl
-IFS=$'\n'
-
-SURFACEID=16777216
-
-while :
-do
- /bin/sleep 1
- surfaces=()
- for line in $($LMC get surfaces 2> /dev/null); do
- if [ "X-" = "X$(echo $line | awk '{print $1}')" ]; then
- surfaceid=$(echo $line | awk '{print $3}')
- if [ "$surfaceid" = "$SURFACEID" ]; then
- $LMC set surface $SURFACEID source region 0 0 384 368
- $LMC set surface $SURFACEID destination region 0 0 384 368
- $LMC set surface $SURFACEID visibility 1
- $LMC set layer 11001 render order $SURFACEID
- exit
- fi
- fi
- done
-done
diff --git a/recipes-demo-hmi/navigation/mapviewer/mapviewer.service b/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
deleted file mode 100644
index 971327cc..00000000
--- a/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
+++ /dev/null
@@ -1,22 +0,0 @@
-[Unit]
-Requires=afm-api-windowmanager@0.service
-After=afm-api-windowmanager@0.service
-
-# mapviewer is a child application which can work with navigation.
-# This app requires mapdata. It has to be stored at /var/mapdata/navi_data_UK .
-# currently the position to be shown is 384x368 surface on screen 1 for cluster demo.
-
-[Service]
-Environment="XDG_RUNTIME_DIR=/run/platform/display"
-ExecStartPre=/bin/sleep 5
-ExecStart=/usr/bin/mapview
-ExecStartPost=/usr/bin/LayerManagerControl create layer 11001 1920 1080
-ExecStartPost=/usr/bin/LayerManagerControl set layer 11001 visibility 1
-ExecStartPost=/usr/bin/LayerManagerControl set screen 1 render order 11001
-ExecStartPost=/usr/AGL/mapviewer/mapviewer-settings.sh
-ExecStop=/usr/bin/killall -s KILL mapview
-Type=simple
-Restart=always
-
-[Install]
-WantedBy=afm-user-session@.target
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
deleted file mode 100644
index a5597083..00000000
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ /dev/null
@@ -1,25 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://mapviewer-settings.sh \
- file://mapviewer.service \
-"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-
-do_install_append() {
- install -d ${D}${prefix}/AGL/${PN}
- install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}${prefix}/AGL/${PN}/
-
- # Install systemd unit file
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -m 644 ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
- fi
-}
-
-SYSTEMD_SERVICE_${PN} = "mapviewer.service"
-
-FILES_${PN} += "${prefix}/AGL/${PN}/"
diff --git a/recipes-demo-hmi/navigation/mapviewer_git.bb b/recipes-demo-hmi/navigation/mapviewer_git.bb
deleted file mode 100644
index 1922e7f1..00000000
--- a/recipes-demo-hmi/navigation/mapviewer_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "AGL meter demo application."
-DESCRIPTION = "This application provides the function of Meter cluster to AGL. "
-HOMEPAGE = "https://github.com/AGLExport/mapviwer"
-SECTION = "apps"
-
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
- file://COPYING;md5=947b2d60ca3872e172034438e9801200"
-
-DEPENDS = " \
- glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
- wayland \
- "
-
-RDEPENDS_${PN} = " navigation "
-
-SRCREV="2dfef5e9141ccb11f83d141c6a7dcbe0ecd49e84"
-SRC_URI="git://github.com/AGLExport/mapviwer.git \
- file://0002-openssl-1.1-fixes.patch \
-"
-
-# To avoid C++ library link failure
-SECURITY_CFLAGS = ""
-
-inherit autotools pkgconfig
-
-S = "${WORKDIR}/git"
-