summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2017-12-11 23:53:06 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-13 23:26:38 +0000
commitdba038a93b0f29a106b92e16175235504eddc8e1 (patch)
treefc78e0f398c1efe0930eb8b9f8dd19f12c6fa5a8
parentf0daf15c14d2f4aa0ea47a1adb2a9f74b69cba12 (diff)
Add initial support for AGL Navigation API
We will commit the initial implementation of AGL Navigation API advanced by Navigation EG. In initial support, AGL 3.0 equivalent API is reimplemented using afm-binder. Change-Id: I5e288c81b22fc31b7d68fcfcafb2325ce4bb75c3 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rw-r--r--recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb b/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb
new file mode 100644
index 00000000..933d47d4
--- /dev/null
+++ b/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Navigation Service Binding"
+DESCRIPTION = "AGL Navigation Service API Binding"
+HOMEPAGE = "https://github.com/AGLExport/agl-service-navigation"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
+SRCREV = "b75e80244471e3486176e5ba476989410ecf5bda"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS = " json-c libdbus-c++ "
+
+inherit cmake aglwgt pkgconfig