summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-05-27 10:59:12 +0800
committerduerpei <duep.fnst@fujitsu.com>2022-05-27 10:59:12 +0800
commiteb0faffd70335e38a51ea153f75b6a2c4ac3e3c5 (patch)
tree6499deb76361c86865a249ae49142189e39e2ebe
parent84c446d08eff4b519986946ac89b0f742aab1381 (diff)
dbus_agldemo: Fix recipe style error
The bitbake recipe has style guide at https://www.openembedded.org/wiki/Styleguide In do_install Don't use mkdir to create destination directories, use install -d instead. Bug-AGL: SPEC-4401 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: If5a9331532d9777cad1c0f55d8a1105932e97872
-rw-r--r--recipes-core/dbus/dbus_agldemo.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/dbus/dbus_agldemo.inc b/recipes-core/dbus/dbus_agldemo.inc
index 193db5df..826584c0 100644
--- a/recipes-core/dbus/dbus_agldemo.inc
+++ b/recipes-core/dbus/dbus_agldemo.inc
@@ -16,7 +16,7 @@ do_install:append() {
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.
- mkdir -p ${D}${sysconfdir}/systemd/user/default.target.wants/
+ install -d ${D}${sysconfdir}/systemd/user/default.target.wants/
ln -sf ${systemd_user_unitdir}/dbus.socket ${D}${sysconfdir}/systemd/user/default.target.wants/dbus.socket
fi
fi