summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/navigation
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-demo/navigation
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-demo/navigation')
-rw-r--r--_to_remove/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini9
-rw-r--r--_to_remove/recipes-demo/navigation/ondemandnavi-config_1.0.bb21
-rw-r--r--_to_remove/recipes-demo/navigation/ondemandnavi_git.bb31
-rw-r--r--_to_remove/recipes-demo/navigation/poiapp-api-key_1.0.bb21
-rw-r--r--_to_remove/recipes-demo/navigation/poiapp/0001-add-display-permission.patch21
-rw-r--r--_to_remove/recipes-demo/navigation/poiapp_git.bb23
-rw-r--r--_to_remove/recipes-demo/navigation/tbtnavi_git.bb38
7 files changed, 164 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini b/_to_remove/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
new file mode 100644
index 000000000..f99c4483d
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
@@ -0,0 +1,9 @@
+{
+ "mapAccessToken":"MAPBOX_ACCESS_TOKEN",
+ "speed":60,
+ "interval":100,
+ "latitude":36.1363,
+ "longitude":-115.151,
+ "mapStyleUrls":"styles/v1/mapbox/streets-v11",
+ "enableOSM":true
+}
diff --git a/_to_remove/recipes-demo/navigation/ondemandnavi-config_1.0.bb b/_to_remove/recipes-demo/navigation/ondemandnavi-config_1.0.bb
new file mode 100644
index 000000000..212971f26
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/ondemandnavi-config_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL Reference On Demand Navigation application config."
+DESCRIPTION = "Config file for on-demand navigation app."
+HOMEPAGE = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+SECTION = "apps"
+LICENSE = "Proprietary"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+SRC_URI = "file://naviconfig.ini \
+ "
+
+inherit allarch
+
+MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
+ sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
+}
diff --git a/_to_remove/recipes-demo/navigation/ondemandnavi_git.bb b/_to_remove/recipes-demo/navigation/ondemandnavi_git.bb
new file mode 100644
index 000000000..5264ba633
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/ondemandnavi_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Navigation application."
+DESCRIPTION = "AGL demonstration Navigation application based on QtLocation widget."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 aglwgt pkgconfig
+
+RDEPENDS:${PN} += " \
+ qtlocation \
+ flite \
+ libqtappfw \
+ openjtalk \
+ gstreamer1.0 \
+ ondemandnavi-config \
+ agl-service-navigation \
+"
+
+RPROVIDES:${PN} = "virtual/navigation"
+
diff --git a/_to_remove/recipes-demo/navigation/poiapp-api-key_1.0.bb b/_to_remove/recipes-demo/navigation/poiapp-api-key_1.0.bb
new file mode 100644
index 000000000..d353d7dd5
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/poiapp-api-key_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL Reference POI application API key."
+DESCRIPTION = "Preload the API key for the AGL POI application."
+HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION = "apps"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+inherit allarch
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_compile[noexec] = "1"
+
+POIAPP_CLIENT_ID ?= ""
+POIAPP_API_KEY ?= ""
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
+ echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
+}
diff --git a/_to_remove/recipes-demo/navigation/poiapp/0001-add-display-permission.patch b/_to_remove/recipes-demo/navigation/poiapp/0001-add-display-permission.patch
new file mode 100644
index 000000000..25a8fc313
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/poiapp/0001-add-display-permission.patch
@@ -0,0 +1,21 @@
+Add display permission
+
+Add display permission required to work with the running as non-root
+change for applications.
+
+Upstream-Status: pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/config.xml.in b/config.xml.in
+index b8cfccd..bec206d 100755
+--- a/config.xml.in
++++ b/config.xml.in
+@@ -13,6 +13,7 @@
+ <feature name="urn:AGL:widget:required-permission">
+ <param name="urn:AGL:permission::public:no-htdocs" value="required" />
+ <param name="http://tizen.org/privilege/internal/dbus" value="required" />
++ <param name="urn:AGL:permission::public:display" value="required" />
+ </feature>
+ <license>GPL</license>
+ </widget>
diff --git a/_to_remove/recipes-demo/navigation/poiapp_git.bb b/_to_remove/recipes-demo/navigation/poiapp_git.bb
new file mode 100644
index 000000000..08e174f74
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/poiapp_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "AGL Reference POI application."
+DESCRIPTION = "This application provides the function of destination search to AGL. It uses the API provided by AGL Reference Navigation. This application uses yelp WebAPI."
+HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION = "apps"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
+
+DEPENDS = " \
+ qtbase \
+ json-c \
+ libhomescreen \
+ libqtappfw \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS:${PN} = "qtbase libqtappfw"
diff --git a/_to_remove/recipes-demo/navigation/tbtnavi_git.bb b/_to_remove/recipes-demo/navigation/tbtnavi_git.bb
new file mode 100644
index 000000000..a4f22545f
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/tbtnavi_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "AGL Reference Navigation Cluster Streaming application"
+DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtLocation widget."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
+ file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
+ file://LICENSE.mapbox-variant;md5=79558839a9db3e807e4ae6f8cd100c1c \
+ file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
+"
+
+DEPENDS = " \
+ qtbase \
+ qtquickcontrols2 \
+ qtlocation \
+ libqtappfw \
+ wayland-native \
+ qtwayland-native \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 aglwgt pkgconfig
+
+RDEPENDS:${PN} += " \
+ qtlocation \
+ ondemandnavi-config \
+ agl-service-navigation \
+ agl-service-signal-composer \
+ libqtappfw \
+"