summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb')
-rw-r--r--recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb b/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
new file mode 100644
index 00000000..6626811d
--- /dev/null
+++ b/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "AGL demo custom QtQuickControls2 widgets"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/src/qtquickcontrols2-agl"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+DEPENDS = "qtquickcontrols2"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http"
+SRCREV = "${AUTOREV}"
+
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_QML}/AGL/Demo/Controls/*"
+
+RDEPENDS_${PN} += " \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtsvg-plugins \
+"