From e3e399730736deb17b4fa36f2fedda39cf510243 Mon Sep 17 00:00:00 2001
From: Scott Murray <scott.murray@konsulko.com>
Date: Tue, 21 Dec 2021 10:00:54 -0500
Subject: Add updated demo applications back

Add updated recipes for the dashboard, hvac, ondemandnavi, and
settings Qt demo applications, as well as for the libqtappfw library
they use and its new dependency bluez-glib.  The applications are
added back to the packagegroup-agl-demo-platform as they were
before.  Also remove a couple of leftover things in the packagegroup
recipe to clean up.

Bug-AGL: SPEC-4182

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I0ea36c809d9126284c597cd79eded8ab031205da
---
 recipes-demo/dashboard/dashboard_git.bb            | 30 +++++++++++++++++++
 recipes-demo/hvac/hvac_git.bb                      | 34 ++++++++++++++++++++++
 recipes-demo/libqtappfw/libqtappfw_git.bb          | 20 +++++++++++++
 .../navigation/ondemandnavi-config/naviconfig.ini  |  9 ++++++
 recipes-demo/navigation/ondemandnavi-config_1.0.bb | 21 +++++++++++++
 recipes-demo/navigation/ondemandnavi_git.bb        | 29 ++++++++++++++++++
 recipes-demo/settings/settings_git.bb              | 34 ++++++++++++++++++++++
 7 files changed, 177 insertions(+)
 create mode 100644 recipes-demo/dashboard/dashboard_git.bb
 create mode 100644 recipes-demo/hvac/hvac_git.bb
 create mode 100644 recipes-demo/libqtappfw/libqtappfw_git.bb
 create mode 100644 recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
 create mode 100644 recipes-demo/navigation/ondemandnavi-config_1.0.bb
 create mode 100644 recipes-demo/navigation/ondemandnavi_git.bb
 create mode 100644 recipes-demo/settings/settings_git.bb

(limited to 'recipes-demo')

diff --git a/recipes-demo/dashboard/dashboard_git.bb b/recipes-demo/dashboard/dashboard_git.bb
new file mode 100644
index 000000000..60ff6370a
--- /dev/null
+++ b/recipes-demo/dashboard/dashboard_git.bb
@@ -0,0 +1,30 @@
+SUMMARY     = "Dashboard application"
+DESCRIPTION = "AGL demonstration Dashboard application"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/dashboard"
+SECTION     = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+    qttools-native \
+    qtquickcontrols2 \
+"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtquickcontrols2-agl-style \
+"
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
new file mode 100644
index 000000000..ffa1234fe
--- /dev/null
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -0,0 +1,34 @@
+SUMMARY     = "HVAC application"
+DESCRIPTION = "AGL demonstration HVAC application"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
+SECTION     = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+    qttools-native \
+    qtbase \
+    qtdeclarative \
+    qtquickcontrols2 \
+    libqtappfw \
+"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtquickcontrols2-agl-style \
+    libqtappfw \
+"
diff --git a/recipes-demo/libqtappfw/libqtappfw_git.bb b/recipes-demo/libqtappfw/libqtappfw_git.bb
new file mode 100644
index 000000000..edf2af04f
--- /dev/null
+++ b/recipes-demo/libqtappfw/libqtappfw_git.bb
@@ -0,0 +1,20 @@
+SUMMARY     = "AGL Qt AppFW Library"
+DESCRIPTION = "libqtappfw"
+HOMEPAGE    = "http://docs.automotivelinux.org"
+SECTION     = "libs"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "0fee9bfb0f656b78f34c44542329760be2980892"
+S       = "${WORKDIR}/git/"
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "2.0+git${SRCPV}"
+
+inherit cmake_qt5
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini b/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
new file mode 100644
index 000000000..f99c4483d
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
@@ -0,0 +1,9 @@
+{
+	"mapAccessToken":"MAPBOX_ACCESS_TOKEN",
+	"speed":60,
+	"interval":100,
+	"latitude":36.1363,
+	"longitude":-115.151,
+	"mapStyleUrls":"styles/v1/mapbox/streets-v11",
+	"enableOSM":true
+}
diff --git a/recipes-demo/navigation/ondemandnavi-config_1.0.bb b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
new file mode 100644
index 000000000..212971f26
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY     = "AGL Reference On Demand Navigation application config."
+DESCRIPTION = "Config file for on-demand navigation app."
+HOMEPAGE    = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+SECTION     = "apps"
+LICENSE     = "Proprietary"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+SRC_URI = "file://naviconfig.ini \
+          "
+
+inherit allarch
+
+MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
+
+do_compile[noexec] = "1"
+
+do_install () {
+    install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
+    sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
+}
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
new file mode 100644
index 000000000..3b9fce4d5
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -0,0 +1,29 @@
+SUMMARY     = "Navigation application."
+DESCRIPTION = "AGL demonstration Navigation application based on QtLocation widget."
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
+SECTION     = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
+    qtlocation \
+    flite \
+    libqtappfw \
+    openjtalk \
+    gstreamer1.0 \
+    ondemandnavi-config \
+"
diff --git a/recipes-demo/settings/settings_git.bb b/recipes-demo/settings/settings_git.bb
new file mode 100644
index 000000000..4dd151355
--- /dev/null
+++ b/recipes-demo/settings/settings_git.bb
@@ -0,0 +1,34 @@
+SUMMARY     = "Settings application"
+DESCRIPTION = "AGL demonstration Settings application"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
+SECTION     = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+    qtbase \
+    qtdeclarative \
+    qtquickcontrols2 \
+    qtvirtualkeyboard \
+    libqtappfw \
+"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S  = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtquickcontrols2-agl-style \
+    libqtappfw \
+"
-- 
cgit