?README-AGL.md: The Automotive Grade Linux Distribution ====================================================== AGL is creating an automotive specific Linux distribution (AGL UCB) that unifies the software that has been written in a number of places already, such as GENIVI and Tizen IVI. The layer 'meta-agl' provides a minimal set of software to boot system of AGL Distribution. 'meta-agl' is the minimal core which is used build AGL profiles on top of it. The reference UI is part of 'meta-agl-demo'. Additional components like the security framework are part of 'meta-agl-extra'. The AGL community appreciates feedback, ideas, suggestion, bugs and documentation just as much as code. Please join the irc conversation at the #automotive channel on irc.freenode.net and our mailing list. For infomation for subscribing to the mailing list [automotive-discussions](http://lists.linuxfoundation.org/mailman/listinfo/automotive-discussions) For information about AGL Distribution, see the [AGL Distribution](https://wiki.automotivelinux.org/agl-distro) For information abount Getting started with AGL [here](https://wiki.automotivelinux.org/start/getting-started) For information about contributing to the AGL Distro [here](https://wiki.automotivelinux.org/agl-distro/contributing) Quick start guide ----------------- The latest version is available at [AGL wiki](https://wiki.automotivelinux.org/agl-distro/source-code) for the following targets: * [QEMU](https://wiki.automotivelinux.org/agl-distro/source-code) * [Renesas Porter board](https://wiki.automotivelinux.org/start/building_for_the_renesas_r-car_m2) * [Raspberry Pi 2/3](https://wiki.automotivelinux.org/agl-distro/agl-raspberrypi) To build an image from 'meta-agl' 1. Prepare repo: > $ mkdir ~/bin > $ export PATH=~/bin:$PATH > $ curl https://storage.googleapis.com/git-repo-downloads/repo > ~/bin/repo > $ chmod a+x ~/bin/repo 2. Get all layers: > $ repo init -u https://gerrit.automotivelinux.org/gerrit/AGL/AGL-repo > $ repo sync 3. Check available targets and extensions, select target machine: > $ source meta-agl/scripts/aglsetup.sh -h > $ source meta-agl/scripts/aglsetup.sh -m porter 4. Build agl-image-ivi > $ bitbake agl-image-ivi To build the agl-demo-platform (as demo'ed @ALS) replace 3. and 4. with: 3. Check available targets and extensions, select target machine: > $ source meta-agl/scripts/aglsetup.sh -h > $ source meta-agl/scripts/aglsetup.sh -m porter agl-demo [agl-appfw-smack] [agl-devel] [agl-netboot] 4. Build agl-demo-platform > $ bitbake agl-demo-platform Note: this uses more layers and not only meta-agl AGL Layers and dependencies: ---------------------------- Check the README.md of the respective layers: - meta-agl (= core, no UI) - meta-agl-demo (= reference UI) - meta-agl-extra (= extra components) In addition, the reference hardware (Renesas R-Car Gen2 / porter) has this dependency: URI: https://gerrit.automotivelinux.org/gerrit/AGL/meta-renesas > branch: agl-1.0-bsp-1.8.0 > tested revision: 82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 Supported Machines ------------------ Reference hardware: * QEMU (x86-64) - emulated machine: qemux86-64 * Renesas R-Car Gen2 (R-Car M2) - machine: porter Community contributed hardware: * See: https://wiki.automotivelinux.org/agl-distro#supported_hardware Supported Target of bitbake --------------------------- meta-agl: * `agl-image-ivi` The baseline image of AGL Distributions (console only) * `agl-image-minimal` For internal use to develop distribution (experimental) * `agl-image-weston` For internal use to develop distribution (experimental) meta-agl-demo: * `agl-demo-platform` The demo/reference image (with graphical UI) Run this command for a full list of machines, features and targets: > $ source ./meta-agl/scripts/aglsetup.sh -h Supposed Directory Tree of Layers to build ------------------------------------------- > $ repo init -u https://gerrit.automotivelinux.org/gerrit/AGL/AGL-repo > $ repo sync > $ tree -L 1 . |-- meta-agl |-- meta-agl-demo |-- meta-agl-devel |-- meta-agl-extra |-- meta-amb |-- meta-fsl-arm |-- meta-fsl-arm-extra |-- meta-intel |-- meta-intel-iot-security |-- meta-openembedded |-- meta-qcom |-- meta-qt5 |-- meta-raspberrypi |-- meta-renesas |-- meta-rust |-- meta-security-isafw |-- meta-ti `-- poky 18 directories, 0 files Build a QEMU image ------------------ You can build a QEMU image using the following steps: (latest version here: https://wiki.automotivelinux.org/agl-distro/source-code) To build an image from 'meta-agl' 1. Prepare repo: > $ mkdir ~/bin > $ export PATH=~/bin:$PATH > $ curl https://storage.googleapis.com/git-repo-downloads/repo > ~/bin/repo > $ chmod a+x ~/bin/repo 2. Get all layers: > $ repo init -u https://gerrit.automotivelinux.org/gerrit/AGL/AGL-repo > $ repo sync 3. Check available targets and extensions, select target machine: > $ source meta-agl/scripts/aglsetup.sh -h > $ source meta-agl/scripts/aglsetup.sh -m qemux86-64 Alternatively, to enable the reference UI feature ('agl-demo'): > $ source meta-agl/scripts/aglsetup.sh -m qemux86-64 agl-demo Alternatively, to also enable also the security framework ('agl-appfw-smack'): > $ source meta-agl/scripts/aglsetup.sh -m qemux86-64 agl-demo agl agl-appfw-smack Alternatively, to also enable debugging tools ('agl-devel') and the network-boot (nbd) capabilities ('agl-netboot'): > $ source meta-agl/scripts/aglsetup.s
SUMMARY     = "HVAC application"
DESCRIPTION = "AGL demonstration HVAC application"
HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
SECTION     = "apps"

LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"

DEPENDS = " \
    qttools-native \
    qtbase \
    qtdeclarative \
    qtquickcontrols2 \
    libqtappfw \
"

PV = "2.0+git${SRCPV}"

SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "c173b5b5fbdb9013304ad62e0dc8f8bb9a072e7d"

S = "${WORKDIR}/git"

inherit qmake5 <