summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-10-01 01:44:46 +0900
committerNaoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp>2024-10-09 16:49:01 +0000
commit5406db62a6f753155050f00f68e09a71decf070d (patch)
tree673ddd917be9e1234049fc4c4c63405150e3da2d /meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
parent0905846dec112d69a532dac26bd2e31ef94d35d7 (diff)
Update each apps to migrate Qt6
The AGL IC container integration migrate to Qt6 from Qt5 now. Each Apps needs modification. This patch change rev and environment setting. Bug-AGL: SPEC-5162 Change-Id: Ib7273fc13d5ab381bed7675662bd1cdc7f941c33 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb')
-rw-r--r--meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb31
1 files changed, 14 insertions, 17 deletions
diff --git a/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb b/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
index 568eb066..ec199ac7 100644
--- a/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
+++ b/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
@@ -1,29 +1,26 @@
-SUMMARY = "Momiyama home screen example"
-DESCRIPTION = "The momiscreen is a home screen example. \
- The momiscreen is not require agl-appfw."
+SUMMARY = "Homescreen for AGL Momi IVI"
+DESCRIPTION = "Homescreen for AGL Momi IVI."
LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = " \
+ qttools-native \
qtbase \
- qtquickcontrols2 \
- qtgraphicaleffects \
- qtsvg \
- "
+ qtdeclarative \
+ qtwayland \
+"
-PV = "1.0.0"
+PV = "2.0.0"
SRC_URI = "git://git.automotivelinux.org/apps/momiscreen;protocol=https;branch=${AGL_BRANCH} \
file://momiscreen.service \
file://momiscreen \
"
-SRCREV = "22b44f911bf6c53298055626cef671a24e9e9069"
+SRCREV = "88fb60ad9d0c673f868d907ca451462ec16c9d7f"
S = "${WORKDIR}/git"
-inherit qmake5 systemd
-
-QT_INSTALL_PREFIX = "/usr"
+inherit cmake qt6-cmake systemd pkgconfig
do_install:append() {
install -d ${D}/${systemd_unitdir}/system
@@ -33,11 +30,11 @@ do_install:append() {
install -m 0755 ${WORKDIR}/momiscreen ${D}${sysconfdir}/default/
}
-FILES:${PN} += " \
- ${systemd_unitdir} \
- ${sysconfdir}/*/* \
- "
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} = "momiscreen.service"
-RDEPENDS:${PN} = "qtsvg qtsvg-plugins qtsvg-qmlplugins"
+RDEPENDS:${PN} = " \
+ qtbase \
+ qtdeclarative \
+ qtwayland \
+"