summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb b/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb
new file mode 100644
index 00000000..e34abd59
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "llvmlite prebuilt binary"
+HOMEPAGE = "https://github.com/numba/llvmlite"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=a15ea9843f27327e08f3c5fbf8043a2b"
+
+SRCURIWHEEL:aarch64 += "https://files.pythonhosted.org/packages/bf/f1/4c205a48488e574ee9f6505d50e84370a978c90f08dab41a42d8f2c576b6/llvmlite-0.43.0-cp312-cp312-manylinux_2_17_aarch64.manylinux2014_aarch64.whl"
+SRCURIWHEEL:x86-64 += "https://files.pythonhosted.org/packages/00/5f/323c4d56e8401c50185fd0e875fcf06b71bf825a863699be1eb10aa2a9cb/llvmlite-0.43.0-cp312-cp312-manylinux_2_17_x86_64.manylinux2014_x86_64.whl"
+SRC_URI = " ${SRCURIWHEEL} "
+SRC_URI:append = " file://LICENSE "
+
+SRCURICHECKSUM:x86-64 = "df6509e1507ca0760787a199d19439cc887bfd82226f5af746d6977bd9f66844"
+SRCURICHECKSUM:aarch64 = "eccce86bba940bae0d8d48ed925f21dbb813519169246e2ab292b5092aba121f"
+SRC_URI[sha256sum] = "${SRCURICHECKSUM}"
+
+COMPATIBLE_MACHINE = "null"
+COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:x86-64 = "(.*)"
+
+DEPENDS += " unzip-native"
+
+RDEPENDS:${PN} += " zlib"
+
+do_install() {
+ mkdir -p ${WORKDIR}/llvmlite-0.43.0
+ unzip ${WORKDIR}/$(basename ${SRC_URI}) -d ${WORKDIR}/llvmlite-0.43.0
+ install -d ${D}/usr/lib/python3.12/site-packages
+ cp -R ${WORKDIR}/llvmlite-0.43.0/* ${D}/usr/lib/python3.12/site-packages/
+}
+
+do_configure:prepend() {
+ export LD_LIBRARY_PATH="${D}/usr/lib/python3.12/site-packages/llvmlite/binding:${LD_LIBRARY_PATH}"
+}
+
+FILES:${PN} += "/usr/lib/python3.12/site-packages/* "