summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch b/meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch
deleted file mode 100644
index 05b6133a..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-scipy/files/static-lib.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/scipy/stats/setup.py b/scipy/stats/setup.py
-index 52a5a36f0..fb5c16a6b 100644
---- a/scipy/stats/setup.py
-+++ b/scipy/stats/setup.py
-@@ -64,10 +64,10 @@ def configuration(parent_package='', top_path=None):
- biasedurn_libs = []
- biasedurn_libdirs = []
- else:
-- biasedurn_libs = ['npyrandom', 'npymath']
-- biasedurn_libdirs = [join(np.get_include(),
-- '..', '..', 'random', 'lib')]
-- biasedurn_libdirs += get_info('npymath')['library_dirs']
-+ biasedurn_libs = [join(os.environ["NUMPY_INCLUDE_PATH"],
-+ '..', '..', 'random', 'lib', 'libnpyrandom.a')]
-+ biasedurn_libs.append([join(os.environ["NUMPY_INCLUDE_PATH"],
-+ '..', '..', 'core', 'lib', 'libnpymath.a')])
-
- ext = config.add_extension(
- '_biasedurn',
-@@ -79,11 +79,10 @@ def configuration(parent_package='', top_path=None):
- 'biasedurn/stoc1.cpp',
- 'biasedurn/stoc3.cpp'],
- include_dirs=[np.get_include()],
-- library_dirs=biasedurn_libdirs,
-- libraries=biasedurn_libs,
- define_macros=[('R_BUILD', None)],
- language='c++',
- depends=['biasedurn/stocR.h'],
-+ extra_objects=biasedurn_libs,
- )
- ext._pre_build_hook = pre_build_hook
-