From fca7f231bf522024d50303c8f6c6adc3b0b5dee6 Mon Sep 17 00:00:00 2001
From: Jacobo Aragunde Pérez <jaragunde@igalia.com>
Date: Wed, 27 Nov 2019 11:05:01 +0100
Subject: meta-html5-framework: define html-only image
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The layer now defines a standalone image agl-image-graphical-html5,
containing only the minimum packages to run the web application
manager (WAM). No webapps are included.

It redefines packagegroups to use the more standard names
agl-profile-graphical-html5 and agl-appfw-html5.

It also adds a dependency on agl-profile-graphical, so we don't
require users to add other features explicitly.

The .bbappends for agl-demo-platform* images have been removed, so the
layer doesn't depend on meta-agl-demo. We will provide image
definitions for WAM + demo apps in meta-agl-demo in a later commit.

To sum up, an HTML-only image can be built with:

  aglsetup.sh -m $MACHINE agl-html5-framework
  bitbake agl-image-graphical-html5

To add WAM to an agl-demo-platform image, both agl-demo and
agl-html5-framework features must be enabled, and this must be added
to local.conf or local.dev.inc:

  IMAGE_INSTALL_append = " packagegroup-agl-appfw-html5"

Bug-AGL: SPEC-2322

Change-Id: I648dd9f509faf77bf0c8520c9773de073865b90e
Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
---
 .../images/agl-demo-platform-crosssdk.bbappend                 |  3 ---
 .../recipes-platform/images/agl-demo-platform.bbappend         |  3 ---
 .../recipes-platform/images/agl-image-graphical-html5.bb       | 10 ++++++++++
 .../recipes-platform/images/agl-image-graphical-html5.inc      |  9 +++++++++
 4 files changed, 19 insertions(+), 6 deletions(-)
 delete mode 100644 meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend
 delete mode 100644 meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend
 create mode 100644 meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb
 create mode 100644 meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc

(limited to 'meta-html5-framework/recipes-platform/images')

diff --git a/meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend b/meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend
deleted file mode 100644
index d5d978dd..00000000
--- a/meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-IMAGE_INSTALL_append += "\
-    packagegroup-agl-demo-platform-html5 \
-    "
diff --git a/meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend b/meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend
deleted file mode 100644
index d5d978dd..00000000
--- a/meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-IMAGE_INSTALL_append += "\
-    packagegroup-agl-demo-platform-html5 \
-    "
diff --git a/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb
new file mode 100644
index 00000000..0ec6829e
--- /dev/null
+++ b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb
@@ -0,0 +1,10 @@
+SUMMARY = "An image containing all packages required to run web applications"
+
+require agl-image-graphical-html5.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+    packagegroup-agl-profile-graphical-html5 \
+    "
+
diff --git a/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc
new file mode 100644
index 00000000..21f3b19a
--- /dev/null
+++ b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc
@@ -0,0 +1,9 @@
+require recipes-platform/images/agl-image-minimal.inc
+
+IMAGE_FEATURES += "splash"
+
+IMAGE_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ssh-server-dropbear' , '', d)}"
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
-- 
cgit