summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-13 16:55:35 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-13 16:55:35 +0000
commitd873359da56e0de9e33ef0378f16a0c9b5605010 (patch)
tree79efdc0942c40119452c4f9fe07cff4ae19b613b /meta-sota/recipes-support/libgsystem/libgsystem_git.bb
parent268d4d9d4c1305a02a23ac7e0e68653eed98707f (diff)
parent798818884c21a743f17e26eda22ceb433b69a3c1 (diff)
Merge "Build OSTree natively, and its dependencies as well"
Diffstat (limited to 'meta-sota/recipes-support/libgsystem/libgsystem_git.bb')
-rw-r--r--meta-sota/recipes-support/libgsystem/libgsystem_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-sota/recipes-support/libgsystem/libgsystem_git.bb b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
new file mode 100644
index 0000000..4b1eb49
--- /dev/null
+++ b/meta-sota/recipes-support/libgsystem/libgsystem_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SRC_URI = "gitsm://github.com/GNOME/libgsystem.git"
+SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep
+
+DEPENDS += "attr glib-2.0 pkgconfig libcap"
+RDEPENDS_${PN} = "xz systemd"
+
+RDEPENDS_${PN}_remove_class-native = "systemd-native"
+
+BBCLASSEXTEND = "native"
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+do_configure() {
+ NOCONFIGURE=true ./autogen.sh
+ oe_runconf
+}
+
+do_compile_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
+FILES_${PN} += " \
+ ${datadir} \
+ ${datadir}/gir-1.0 \
+ ${datadir}/gir-1.0/GSystem-1.0.gir \
+ ${libdir}/girepository-1.0/ \
+ ${libdir}/girepository-1.0/GSystem-1.0.typelib \
+"