summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnusha Gugale <external.agogale@jp.adit-jv.com>2021-09-02 11:19:06 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-09-27 07:22:28 +0000
commit8c4b3948fa6aa8d84e4fe5cb4b3b8cc05ce04c5e (patch)
tree46de0026ed55dc2f05a4b694faad247396fc70bf
parentfab29403e0da3ff8ee6c9fef76e115aa53a06ff7 (diff)
Make the mode configurable at build time for the waltham transmitter
- Create a TRANSMITTER_OUTPUT_MODE variable with a known default - Use this to update the transmitter-output.cfg fragment - Users can redefine this variable based on their needs - While at it do the same for HOST and PORT Bug-AGL: SPEC-4030 Signed-off-by: Anusha Gugale <external.agogale@jp.adit-jv.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: I32374186bdce3171a1f7ad4026e10c6448edaec6 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26609 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb15
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg.in (renamed from meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg)0
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index 8842a5a46..c635d7b2f 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -10,7 +10,7 @@ SRC_URI = " \
file://hdmi-a-1-180.cfg \
file://hdmi-a-1-270.cfg \
file://remote-output.cfg \
- file://transmitter-output.cfg \
+ file://transmitter-output.cfg.in \
file://virtual-0.cfg \
file://virtual-180.cfg \
file://virtual-270.cfg \
@@ -31,6 +31,19 @@ WESTON_FRAGMENTS = "core shell ${WESTON_DISPLAYS}"
# On-target weston.ini directory
weston_ini_dir = "${sysconfdir}/xdg/weston"
+# Options for the user to change in local.conf
+# e.g. TRANSMITTER_OUTPUT_MODE = "1080x1488"
+TRANSMITTER_OUTPUT_MODE ??= "640x720@30"
+TRANSMITTER_OUTPUT_HOST ??= "192.168.20.99"
+TRANSMITTER_OUTPUT_PORT ??= "5005"
+
+do_configure() {
+ sed -e "s#mode=.*#mode=${TRANSMITTER_OUTPUT_MODE}#" \
+ -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
+ -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
+ ${WORKDIR}/transmitter-output.cfg.in > ${WORKDIR}/transmitter-output.cfg
+}
+
do_compile() {
# Put all of our cfg files together for a default portrait
# orientation configuration
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg.in
index e77f74ec0..e77f74ec0 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg.in