aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-11-07 00:43:24 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2015-11-08 07:02:17 +0000
commit6e22b075ed57a0fb3ed5af68e029c291adc309d5 (patch)
treef6c7c5c70c6d8f070e03dd50f6d5c386248c6b65
parent6f0bdfc2c3d11cf18d149593a189c48a2a14e3d2 (diff)
Fix compilation of AMB if icecc is installed on the build machine.
If the buildhost has icecc installed, AMBs cmake file will hardcode the compiler to icecc (understandable, but not a good idea for crosscompiling). In our case this leads to the replacement of the compiler supplied by the build environment with icecc. This breaks the compilation. We turn off the icecc detection, which is unfortunately on by default. Plus fixes for a few typos. Change-Id: Ibc28d3d697f1769f134e2a8f630e42058255bf3b Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
index b921b99c8..324fa26f0 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
@@ -11,9 +11,9 @@ inherit cmake systemd
PV = "0.12+git${SRCPV}"
-# The 'gpsd' cause conflict bluez4 and bluez5 because
+# The 'gpsd' leads to a conflict between bluez4 and bluez5 because
# meta-openembedded/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb is able to
-# select bluez4 only instead AGL Distro choosed bluez5 at Changes 4141.
+# select bluez4 only instead AGL Distro choose bluez5 at changeset 4141.
# <https://gerrit.automotivelinux.org/gerrit/#/c/4141/>
#
# As temporary treatment, removing 'gpsd' from DEPENDS will let bitbake to build correctly.
@@ -33,6 +33,12 @@ SYSTEMD_SERVICE_${PN} = "ambd.service"
S = "${WORKDIR}/git"
+# amb detects icecc in cmake and would override the
+# compiler selection of yocto. This breaks the build
+# if icecc is installed on the host.
+# -> Disable the detection in cmake.
+EXTRA_OECMAKE += " -Denable_icecc=OFF"
+
do_install_append() {
mv ${D}/usr/include/amb/* ${D}/usr/include