aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-16 17:55:29 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:39:18 +0000
commit1ae3f9a142e29756dec91acc29434f74ff456035 (patch)
tree90a48585bab1e44ee24be7b81c4f863819555b65
parent523f4c685e9271b58f40d355f253362690abfc53 (diff)
meta-ivi-common: add recipe for fsfuzzer (JTA:Functional.fsfuzz)
fsfuzzer binary is needed in JTA functional test 'fsfuzz' Change-Id: Icb82fb82b8785d8ae2c784934fa9e32e2b520ef6 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-ivi-common/recipes-test/fsfuzzer/files/0001-fix_missing_header_sys_stat.patch11
-rw-r--r--meta-ivi-common/recipes-test/fsfuzzer/fsfuzzer_0.7.bb18
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/fsfuzzer/files/0001-fix_missing_header_sys_stat.patch b/meta-ivi-common/recipes-test/fsfuzzer/files/0001-fix_missing_header_sys_stat.patch
new file mode 100644
index 000000000..e834becf3
--- /dev/null
+++ b/meta-ivi-common/recipes-test/fsfuzzer/files/0001-fix_missing_header_sys_stat.patch
@@ -0,0 +1,11 @@
+diff -urN fsfuzzer-0.7.orig/fstest.c fsfuzzer-0.7/fstest.c
+--- fsfuzzer-0.7.orig/fstest.c 2009-01-25 14:50:06.000000000 +0000
++++ fsfuzzer-0.7/fstest.c 2016-06-16 17:49:27.264565819 +0000
+@@ -35,6 +35,7 @@
+ #include <signal.h>
+ #include <sys/file.h>
+ #include <sys/mman.h>
++#include <sys/stat.h>
+
+ #define LOGGIT 1
+ #define CHECK_XATTR 1
diff --git a/meta-ivi-common/recipes-test/fsfuzzer/fsfuzzer_0.7.bb b/meta-ivi-common/recipes-test/fsfuzzer/fsfuzzer_0.7.bb
new file mode 100644
index 000000000..d2ddb59b1
--- /dev/null
+++ b/meta-ivi-common/recipes-test/fsfuzzer/fsfuzzer_0.7.bb
@@ -0,0 +1,18 @@
+SUMMARY = "The fsfuzzer is a filesystem fuzzer tool that does stress tests of various filesystems in a reproducible and logged way."
+DESCRIPTION = "This tool creates initial (valid) filesystem images and then manipulates their binary format and structure for detecting flaws/bugs/design problems in the parsing/handling code for that particular filesystem. The program expects that you have a /media directory. It uses that one for mounting test images in."
+HOMEPAGE = "https://www.ee.oulu.fi/research/ouspg/fsfuzzer"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+SRC_URI = "http://people.redhat.com/sgrubb/files/fsfuzzer-${PV}.tar.gz \
+ file://0001-fix_missing_header_sys_stat.patch \
+ "
+SRC_URI[md5sum] = "d69ac4b67aaba52a889c9188eb456c15"
+SRC_URI[sha256sum] = "094aa17c4f66c525a04e5db5ad444b4a561b6f8e310d0bd70b9ca421cdf0a434"
+
+inherit autotools
+
+# Specify any options you want to pass to the configure script using EXTRA_OECONF:
+EXTRA_OECONF = ""
+