aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-06-15 13:13:42 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-06-19 19:34:50 +0000
commit8176e8bfdeb01950841bc300dd82f4da27a65c39 (patch)
treeae44c2af4560458fa1ab32c247af6c88c55658b4
parent13ea965a88cd38fcc94a00c8ecaca1eab34a8d80 (diff)
ostree: Add OSTree
OSTree is a tool for managing bootable, immutable, versioned filesystem trees. Is will be used to apply updates downloaded by RVI SOTA client. Bug-AGL: SPEC-194 Change-Id: I286b9ce8631c6ef8632f134f89e85b462cb39fd3 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-agl/recipes-sota/ostree/ostree_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl/recipes-sota/ostree/ostree_git.bb b/meta-agl/recipes-sota/ostree/ostree_git.bb
new file mode 100644
index 000000000..9009685d4
--- /dev/null
+++ b/meta-agl/recipes-sota/ostree/ostree_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SRC_URI = "gitsm://git.gnome.org/ostree.git;branch=master"
+SRCREV="${AUTOREV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4"
+
+RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
+
+inherit autotools-brokensep
+
+EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
+
+FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
+
+BBCLASSEXTEND = "native"
+
+do_configure() {
+ NOCONFIGURE=true ./autogen.sh
+ oe_runconf
+}