aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-14 09:20:32 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:27:11 +0000
commitacf8cd14ba5b53c774c85d4f7b177d5709be2e59 (patch)
treee1239a39611d1d6ffd5a42818405617019d7a9df
parent49f929e35a8fe1a3c7353ce6bd62b2158e4e9493 (diff)
meta-ivi-common: add recipe for aiostress (JTA:Functional.aiostress)
aio-stress binary is needed in JTA functional test 'aiostress' upstream version found here: https://oss.oracle.com/~mason/aio-stress/ NB: the version referenced in JTA is 0.21 but the new recipe points to 0.22. Change-Id: I382ca2ea843f2367010677c463df2a1b9d02aba7 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-ivi-common/recipes-test/aiostress/aiostress_0.22.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/aiostress/aiostress_0.22.bb b/meta-ivi-common/recipes-test/aiostress/aiostress_0.22.bb
new file mode 100644
index 000000000..7803d74ed
--- /dev/null
+++ b/meta-ivi-common/recipes-test/aiostress/aiostress_0.22.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Async IO testing utility"
+DESCRIPTION = "aio-stress will open or create each file on the command line, and start a series of aio to it.\
+aio is done in a rotating loop. first file1 gets 8 requests, then file2, then file3 etc.\
+As each file finishes writing, it is switched to reads io buffers are aligned in case you want to do raw io"
+HOMEPAGE = "https://oss.oracle.com/~mason/aio-stress/"
+LICENSE = "GPLv2"
+
+S="${WORKDIR}"
+
+LIC_FILES_CHKSUM = "file://${S}/aio-stress.c;md5=ccb5d196a3736bbd835d582a4e2329c3"
+
+SRC_URI = "https://oss.oracle.com/~mason/aio-stress/aio-stress.c"
+SRC_URI[md5sum] = "ccb5d196a3736bbd835d582a4e2329c3"
+SRC_URI[sha256sum] = "3f4cffcc946fb717fff9d8fe932c7c2ee606efff198408d9fbe16955151445f7"
+
+do_compile () {
+ ${CC} -Wall -Wshadow -o aio-stress -lpthread -laio aio-stress.c
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 aio-stress ${D}${bindir}
+}
+