summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominig ar Foll (Intel Open Source) <dominig.arfoll@fridu.net>2016-12-06 23:16:04 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-07 13:19:53 +0000
commit1b4ccafee173eb94dcba9d2a744d86de0daebe91 (patch)
tree620ed0876b6d3663171820c8216b5e1c5ff7230b
parentbd1131005504acfb7eff267f318a72f03366824a (diff)
Enabling HW acceleration for Intel with libva and correct libva incorrect runtime dependency with x11
Change-Id: I175b0d9900d61546cb0f116a1d698ee1f60b84b7 Signed-off-by: Dominig ar Foll (Intel Open Source) <dominig.arfoll@fridu.net> Correct libva incorrect runtime dependency with x11 Change-Id: Ic4231c217c8c63575a98d370c898b8cb04e3a980 Signed-off-by: Dominig ar Foll (Intel Open Source) <dominig.arfoll@fridu.net>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend4
-rw-r--r--templates/machine/intel-corei7-64/50_local.conf.inc7
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend
new file mode 100644
index 000000000..efc194b79
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend
@@ -0,0 +1,4 @@
+# This patch correct a bug in libva1_1.7.0.bb 1.8 inmeta-intel (no clue when it will be fixed)
+# libva.bb calls for an x11 runtime dependency even if wayland is selected
+#
+RDEPENDS_${PN}-egl_remove = "${@base_contains("DISTRO_FEATURES", "x11", "", "${PN}-x11", d)}"
diff --git a/templates/machine/intel-corei7-64/50_local.conf.inc b/templates/machine/intel-corei7-64/50_local.conf.inc
index e88000f5c..7c921b70e 100644
--- a/templates/machine/intel-corei7-64/50_local.conf.inc
+++ b/templates/machine/intel-corei7-64/50_local.conf.inc
@@ -18,3 +18,10 @@ MACHINE = "intel-corei7-64"
#
# All boot message will be off
#APPEND += "quiet"
+
+# Enable Libvaapi for HW accelerated video support
+#
+IMAGE_INSTALL_append = " \
+ libva \
+ va-intel \
+ gstreamer-vaapi-1.0 "