summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-17 06:23:32 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-20 10:28:09 +0000
commit5692de99c4e04d51a6c5da86fea1710d55420873 (patch)
treef98e183bf6d0917a8a68ef65b9b75c39b43fdcce
parent5316a9c2c998a49b63508ed56370ab55a57ab5a6 (diff)
Move genskel to af-binder-tools recipes
This change fixes SPEC-941 and the HAL build by providing the needed afb-genskel for build by recipe and as part of the SDK. v2: move to af-binder folder and align naming to af-binder-devtools add nativesdk-af-binder-devtools to packagegroup nativesdk-packagegroup-sdk-host add af-binder-devtools-native to packagegroup packagegroup-agl-app-framework v3: move af-binder-devtools-native to aglwgt as DEPENDS as there is no -native package to add to the packagegroup-agl-app-framework Bug-AGL: SPEC-941 Change-Id: Iae3c8d958000623b1c84db896307032f5033477d Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/12033 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
-rw-r--r--meta-app-framework/classes/aglwgt.bbclass3
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb19
-rw-r--r--meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend2
3 files changed, 23 insertions, 1 deletions
diff --git a/meta-app-framework/classes/aglwgt.bbclass b/meta-app-framework/classes/aglwgt.bbclass
index ce566abca..aa27c2492 100644
--- a/meta-app-framework/classes/aglwgt.bbclass
+++ b/meta-app-framework/classes/aglwgt.bbclass
@@ -15,6 +15,9 @@ DEPENDS_append = " af-main-native"
# for bindings af-binder is required.
DEPENDS_append = " af-binder"
+# for hal bindings genskel is required.
+DEPENDS_append = " af-binder-devtools-native"
+
do_aglwgt_package() {
cd ${B}
${S}/conf.d/autobuild/agl/autobuild package BUILD_DIR=${B} DEST=${B}/package VERBOSE=TRUE || \
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb
new file mode 100644
index 000000000..d22112f22
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "App Framework Host Utilities (generators, parsers)"
+DESCRIPTION = "The AGL App Framework Host Utilities are used to compile applications"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-host-utilities"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "json-c"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-host-utilities;protocol=https;branch=${AGL_BRANCH}"
+
+SRCREV = "${AGL_DEFAULT_REVISION}"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
index ca0b54f73..fc73e8f3d 100644
--- a/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
+++ b/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -1,2 +1,2 @@
-RDEPENDS_${PN} =+ "nativesdk-af-main-tools"
+RDEPENDS_${PN} =+ "nativesdk-af-main-tools nativesdk-af-binder-devtools"