summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2021-05-12 12:59:13 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-05-13 21:54:39 +0000
commit851c0a09688ef08cfcde596f7a9aa0590876c4f6 (patch)
tree2de3569bf42093cd9a1b241d9538299242b2a695
parentfa55216e21c8a63f9f9b9309edc005ed2bea2485 (diff)
agl-shell-activator_git: Add recipelamprey_11.91.0lamprey/11.91.011.91.0
This adds the recipe for agl-activator/agl-shell-activator, a simple tool that switches (already started) applications. It assumes the first output, but can be enhanced to support use multi output if needed. Bug-AGL: SPEC-3817 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I32f8bb246d75591cd7fc4f7d4b4047ee2b8f1b09 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26348 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
new file mode 100644
index 000000000..fe0b61f85
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = " Application that switches/activates other application's windows "
+DESCRIPTION = " A wayland client and a script that talks with the agl-compositor \
+an tells it to display a specific application. Relies on the appid being \
+started (already) by afm-util or the client shell (homescreen/WAM)"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-shell-activator"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e978448a0d41d826d73890d9c22caf75"
+
+DEPENDS = "wayland wayland-protocols wayland-native agl-compositor"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-shell-activator.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "5bdedb16112fa0faaf16f64ef440f451e9f787e4"
+
+PV = "0.0.10+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig python3native
+
+FILES_${PN} = " ${bindir}/agl-shell-activator \
+ ${bindir}/agl-activator "