summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-01-13 05:30:15 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-01-13 05:44:10 +0900
commit91819725d9e94c05b8faab7a99a9ebae5417a9e2 (patch)
treeb839c6a25d6cfee8c017c49e1f2447f3d6e9c5a0
parentb3084b0edd0bb5c5adcf47fc17f04b6f2cae73e2 (diff)
Weston crushed by ivi-input-controller
When repeat switching between HomeScreen and WebBrowser very quickly, sometimes weston crushed because of segmentation fault of ivi-input-contoller.so. Change-Id: I408158a98f30640fdab9a843331451b5549cb761 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch31
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch
new file mode 100644
index 000000000..636ecf1b9
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch
@@ -0,0 +1,31 @@
+From 97af4843a4705cd7d5b6b69abb9002fd974a5b94 Mon Sep 17 00:00:00 2001
+From: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
+Date: Fri, 12 Jan 2018 01:53:01 +0900
+Subject: [PATCH] Resolve weston cursh when repeat touching very quickly
+
+Weston sometimes crush while the user repeat touching very
+quickly icons/shortcuts on HomeScreen.
+
+Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
+---
+ ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+index b0fe37d..f1a31d0 100644
+--- a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
++++ b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+@@ -557,6 +557,10 @@ touch_grab_up(struct weston_touch_grab *grab, uint32_t time, int touch_id)
+ const struct ivi_layout_interface *interface =
+ seat->input_ctx->ivi_layout_interface;
+
++ /* if touch device has no focused view, there is nothing to do*/
++ if (grab->touch->focus == NULL)
++ return;
++
+ /* For each surface_ctx, check for focus and send */
+ wl_list_for_each(surf_ctx, &seat->input_ctx->surface_list, link) {
+ struct weston_surface *surf, *send_surf;
+--
+2.7.4
+
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
index e20132cab..68e92adb5 100644
--- a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
@@ -10,6 +10,7 @@ SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
file://0001-simple-id-agent-initial-commit.patch;patch=1 \
file://0002-ivi-controller-load-id-agent-module.patch;patch=1 \
file://0003-ivi-controller-add-resize-setting-suit-to-surface-si.patch \
+ file://0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch \
"
S = "${WORKDIR}/git"