aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorentin Labbe <clabbe@baylibre.com>2019-04-12 13:11:44 +0000
committerCorentin Labbe <clabbe@baylibre.com>2019-04-15 08:33:42 +0000
commit1c5e1f26af6e8b91115b45630902381051468dfa (patch)
treeb8c0849524e3cc22c180c40faf82c5358f26ed38
parentfea01d98626fa0f030f87a7f0efbe2d94bb45de8 (diff)
meta-intel: Support the upsquare board
This patch adds the necessary CONFIG for booting the upsquare board. The upsquare have an R8169 ethernet card and need it built-in for the kernel DHCP autoconf to work. The upsquare need some MFD_INTEL configs to boot. The meta-intel miss some CONFIG necessary for LAVA and NBD to works. Bug-AGL: SPEC-2075 Change-Id: I990732c78b53ac591dde83f4e372b420ea558fa7 Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg3
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/files/net-devices.cfg1
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg4
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend8
4 files changed, 16 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg
new file mode 100644
index 000000000..4dcf4036d
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg
@@ -0,0 +1,3 @@
+CONFIG_BLK_DEV_RAM=y
+CONFIG_BLK_DEV_NBD=y
+CONFIG_BLK_DEV_INITRD=y
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/net-devices.cfg b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/net-devices.cfg
index 9d5329a8f..ab88cedc2 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/net-devices.cfg
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/net-devices.cfg
@@ -1 +1,2 @@
CONFIG_IGB=y
+CONFIG_R8169=y
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg
new file mode 100644
index 000000000..7be178bf6
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg
@@ -0,0 +1,4 @@
+CONFIG_MFD_CORE=y
+CONFIG_MFD_INTEL_LPSS=y
+CONFIG_MFD_INTEL_LPSS_ACPI=y
+CONFIG_MFD_INTEL_LPSS_PCI=y
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
index 62c264d12..e159747ae 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
@@ -12,6 +12,14 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
SRC_URI_append = " file://net-devices.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
+# adding specific driver needed by the upsquare board
+SRC_URI_append = " file://upsquare.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/upsquare.cfg"
+
+# adding CONFIG needed by LAVA and NBD
+SRC_URI_append = " file://lava.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/lava.cfg"
+
# Ensure we have a startup.nsh file
SRC_URI_append = " file://startup.nsh"