aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-09-09 18:26:50 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-09-10 15:59:58 +0000
commitf9aa25211303889d6bac7c98e0a4c357e7bceef7 (patch)
treeedd5057b8f467c6091a4ed705d7008ef2b015d0f
parenta66cc5da4dd22f70ea200e8eee5bc51fca379efc (diff)
Fix compilation of nasm-native with newer gcc versionsguppy
Backport of upstream change. http://cgit.openembedded.org/openembedded-core/commit/meta/recipes-devtools?id=e3c76fd3db928fc487e86325df299f3f02ef369c This fixes a FTBS for nasm-native on guppy with gcc 8.2.x . Bug-AGL: SPEC-2806 Change-Id: I44716098f015fb6c707ed4db62a23111fab79001 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/recipes-devtools/nasm/files/0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch27
-rw-r--r--meta-agl-bsp/recipes-devtools/nasm/nasm_%.bbappend3
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-devtools/nasm/files/0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch b/meta-agl-bsp/recipes-devtools/nasm/files/0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch
new file mode 100644
index 000000000..12ae3a94d
--- /dev/null
+++ b/meta-agl-bsp/recipes-devtools/nasm/files/0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch
@@ -0,0 +1,27 @@
+From 77c3a77210d8ca8b94e999c711156e984a8dc737 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 31 Mar 2018 11:05:33 -0700
+Subject: [PATCH] asmlib: Drop pure function attribute from seg_init
+
+seg_init returns void, so it is impure function
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ include/nasmlib.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/nasmlib.h b/include/nasmlib.h
+index 79e866b..b80b7e2 100644
+--- a/include/nasmlib.h
++++ b/include/nasmlib.h
+@@ -191,7 +191,7 @@ int64_t readstrnum(char *str, int length, bool *warn);
+ * seg_init: Initialise the segment-number allocator.
+ * seg_alloc: allocate a hitherto unused segment number.
+ */
+-void pure_func seg_init(void);
++void seg_init(void);
+ int32_t pure_func seg_alloc(void);
+
+ /*
diff --git a/meta-agl-bsp/recipes-devtools/nasm/nasm_%.bbappend b/meta-agl-bsp/recipes-devtools/nasm/nasm_%.bbappend
new file mode 100644
index 000000000..3edf35551
--- /dev/null
+++ b/meta-agl-bsp/recipes-devtools/nasm/nasm_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = " file://0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch"
+