summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-11-07 07:21:26 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-01-18 15:18:33 +0000
commit0e0e11e0900c4cedcc6cb6e92265c6eaf0c814be (patch)
tree0c8baaacd85eb78418387aab8c5c6869c6ad24a3
parent72ff17df1a8946dae6a5ca4f2ed4923d5d597e2f (diff)
meta-agl-profile-core: recipes-connectivity: ofono: change dbus policy to enable modem events
To detect modem addition and removal in the agl-service-telephony binding the interface needs to be enabled in the dbus policy Bug-AGL: SPEC-2117 Change-Id: Ib610188d72404e338c59d64c4b84a183632efb1f Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/ofono/files/ofono.conf30
-rw-r--r--meta-agl-profile-core/recipes-connectivity/ofono/ofono_%.bbappend6
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/ofono/files/ofono.conf b/meta-agl-profile-core/recipes-connectivity/ofono/files/ofono.conf
new file mode 100644
index 000000000..e47214c76
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/ofono/files/ofono.conf
@@ -0,0 +1,30 @@
+<!-- This configuration file specifies the required security policies
+ for oFono core daemon to work. -->
+
+<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+
+ <!-- ../system.conf have denied everything, so we just punch some holes -->
+
+ <policy user="root">
+ <allow own="org.ofono"/>
+ <allow send_destination="org.ofono"/>
+ <allow send_interface="org.ofono.Manager"/>
+ <allow send_interface="org.ofono.SimToolkitAgent"/>
+ <allow send_interface="org.ofono.PushNotificationAgent"/>
+ <allow send_interface="org.ofono.SmartMessagingAgent"/>
+ <allow send_interface="org.ofono.PositioningRequestAgent"/>
+ <allow send_interface="org.ofono.HandsfreeAudioAgent"/>
+ <allow send_interface="org.ofono.Modem"/>
+ </policy>
+
+ <policy at_console="true">
+ <allow send_destination="org.ofono"/>
+ </policy>
+
+ <policy context="default">
+ <deny send_destination="org.ofono"/>
+ </policy>
+
+</busconfig>
diff --git a/meta-agl-profile-core/recipes-connectivity/ofono/ofono_%.bbappend b/meta-agl-profile-core/recipes-connectivity/ofono/ofono_%.bbappend
new file mode 100644
index 000000000..e78eb44be
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/ofono/ofono_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = "file://ofono.conf"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/ofono.conf ${D}${sysconfdir}/dbus-1/system.d/ofono.conf
+}