summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-11-24 16:26:11 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 21:10:07 +0000
commit38c1a71fc36256a886d7d496d4c9cffd629a8f6b (patch)
treed8825e683c83baab0864442873c20152a67338d4
parent254ccf132df29513526190e1fa9789c059514299 (diff)
Add instrument cluster profile definitions
Add definitions for instrument cluster profiles for plain Wayland/Weston based images and images that also include Qt5 support. Due to the current requirement that profiles only be a superset of one parent profile, the Qt5 profile inherits from agl-profile-graphical-qt5 and not agl-profile-cluster as one might expect. This is due to some of the required recipes and bbappends for Qt5 usage only being available in the meta-agl-profile-graphical-qt5 layer. Change-Id: I863b35bdc009775ac204a720bbc2cc85e71c268a Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-profile-cluster-qt5/conf/layer.conf10
-rw-r--r--meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.bb9
-rw-r--r--meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.inc7
-rw-r--r--meta-agl-profile-cluster-qt5/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qt5.bb21
-rw-r--r--meta-agl-profile-cluster/conf/layer.conf10
-rw-r--r--meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.bb9
-rw-r--r--meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.inc7
-rw-r--r--meta-agl-profile-cluster/recipes-platform/packagegroups/packagegroup-agl-profile-cluster.bb20
-rw-r--r--templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-cluster-qt5/included.dep1
-rw-r--r--templates/feature/agl-profile-cluster/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-cluster/included.dep1
12 files changed, 101 insertions, 0 deletions
diff --git a/meta-agl-profile-cluster-qt5/conf/layer.conf b/meta-agl-profile-cluster-qt5/conf/layer.conf
new file mode 100644
index 000000000..30a222971
--- /dev/null
+++ b/meta-agl-profile-cluster-qt5/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "aglprofileclusterqt5"
+BBFILE_PATTERN_aglprofileclusterqt5 = "^${LAYERDIR}/"
+BBFILE_PRIORITY_aglprofileclusterqt5 = "70"
diff --git a/meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.bb b/meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.bb
new file mode 100644
index 000000000..244e2ba48
--- /dev/null
+++ b/meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.bb
@@ -0,0 +1,9 @@
+SUMMARY = "A basic Wayland based cluster image with Qt5 support"
+
+require agl-image-cluster-qt5.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+ profile-cluster-qt5 \
+ "
diff --git a/meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.inc b/meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.inc
new file mode 100644
index 000000000..9f9f530f9
--- /dev/null
+++ b/meta-agl-profile-cluster-qt5/recipes-platform/images/agl-image-cluster-qt5.inc
@@ -0,0 +1,7 @@
+require recipes-platform/images/agl-image-boot.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/meta-agl-profile-cluster-qt5/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qt5.bb b/meta-agl-profile-cluster-qt5/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qt5.bb
new file mode 100644
index 000000000..5436a5617
--- /dev/null
+++ b/meta-agl-profile-cluster-qt5/recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qt5.bb
@@ -0,0 +1,21 @@
+SUMMARY = "The middleware for AGL Qt5 based cluster profile"
+DESCRIPTION = "The set of packages required for AGL Qt5 based Cluster Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-profile-cluster-qt5 \
+ profile-cluster-qt5 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-boot \
+ packagegroup-agl-core-security \
+ packagegroup-agl-graphical-weston \
+ packagegroup-agl-appfw-native-qt5 \
+"
+
+RDEPENDS_profile-cluster-qt5 = "${PN}"
diff --git a/meta-agl-profile-cluster/conf/layer.conf b/meta-agl-profile-cluster/conf/layer.conf
new file mode 100644
index 000000000..4ac5d96a0
--- /dev/null
+++ b/meta-agl-profile-cluster/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "aglprofilecluster"
+BBFILE_PATTERN_aglprofilecluster = "^${LAYERDIR}/"
+BBFILE_PRIORITY_aglprofilecluster = "70"
diff --git a/meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.bb b/meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.bb
new file mode 100644
index 000000000..552d7a74e
--- /dev/null
+++ b/meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.bb
@@ -0,0 +1,9 @@
+SUMMARY = "A basic Wayland based cluster image"
+
+require agl-image-cluster.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+ profile-cluster \
+ "
diff --git a/meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.inc b/meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.inc
new file mode 100644
index 000000000..9f9f530f9
--- /dev/null
+++ b/meta-agl-profile-cluster/recipes-platform/images/agl-image-cluster.inc
@@ -0,0 +1,7 @@
+require recipes-platform/images/agl-image-boot.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/meta-agl-profile-cluster/recipes-platform/packagegroups/packagegroup-agl-profile-cluster.bb b/meta-agl-profile-cluster/recipes-platform/packagegroups/packagegroup-agl-profile-cluster.bb
new file mode 100644
index 000000000..c0c612467
--- /dev/null
+++ b/meta-agl-profile-cluster/recipes-platform/packagegroups/packagegroup-agl-profile-cluster.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The middleware for AGL cluster profile"
+DESCRIPTION = "The set of packages required for AGL Cluster Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-profile-cluster \
+ profile-cluster \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-boot \
+ packagegroup-agl-core-security \
+ packagegroup-agl-graphical-weston \
+"
+
+RDEPENDS_profile-cluster = "${PN}"
diff --git a/templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc b/templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc
new file mode 100644
index 000000000..f1aef074d
--- /dev/null
+++ b/templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc
@@ -0,0 +1,3 @@
+BBLAYERS =+ " \
+ ${METADIR}/meta-agl/meta-agl-profile-cluster-qt5 \
+"
diff --git a/templates/feature/agl-profile-cluster-qt5/included.dep b/templates/feature/agl-profile-cluster-qt5/included.dep
new file mode 100644
index 000000000..21b1fa6bc
--- /dev/null
+++ b/templates/feature/agl-profile-cluster-qt5/included.dep
@@ -0,0 +1 @@
+agl-profile-graphical-qt5
diff --git a/templates/feature/agl-profile-cluster/50_bblayers.conf.inc b/templates/feature/agl-profile-cluster/50_bblayers.conf.inc
new file mode 100644
index 000000000..b430dc7db
--- /dev/null
+++ b/templates/feature/agl-profile-cluster/50_bblayers.conf.inc
@@ -0,0 +1,3 @@
+BBLAYERS =+ " \
+ ${METADIR}/meta-agl/meta-agl-profile-cluster \
+"
diff --git a/templates/feature/agl-profile-cluster/included.dep b/templates/feature/agl-profile-cluster/included.dep
new file mode 100644
index 000000000..032609b8a
--- /dev/null
+++ b/templates/feature/agl-profile-cluster/included.dep
@@ -0,0 +1 @@
+agl-profile-graphical