summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-16 20:39:14 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 21:10:07 +0000
commit4824f74346855b0fd61d22d3e1b9e7f67388e6c3 (patch)
tree59b0c56bbc0ca41dbb20aa04a1fc3c4002a5e3b0
parentbfc73005bcf149a8065683e53939204d02d3517d (diff)
connman: Ignore MOST ethernet interfaces
On systems like the CES demo units with MOST adapters, the virtual ethernet interface created by MOST interferes with connman's management of the shared connection of the Wi-fi and main ethernet interface, eg. the MOST ethernet being present results in the Wi-fi not auto-connecting at boot. To avoid this, ignore the "meth" interfaces by adding them to the blacklist. This seems reasonable, as they are unlikely to be used for internet connectivity. Change-Id: I9b56333df4b4d7e128a765855065efce58abb734 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend2
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/files/main.conf1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index 98729400c..8057fbbc7 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -12,6 +12,6 @@ do_install_append() {
# Need to ignore eth1 in cluster demo setup
if ${@bb.utils.contains('DISTRO_FEATURES', 'agl-cluster-demo-support', 'true', 'false', d)}; then
- echo "NetworkInterfaceBlacklist=vmnet,vboxnet,virbr,ifb,eth1" >> ${D}${sysconfdir}/connman/main.conf
+ sed -i 's/^\(NetworkInterfaceBlacklist=.*\)/\1,eth1/' ${D}${sysconfdir}/connman/main.conf
fi
}
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
index 0bfbe09dc..4dba25b70 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
+++ b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
@@ -1,2 +1,3 @@
[General]
FallbackTimeservers=pool.ntp.org
+NetworkInterfaceBlacklist=vmnet,vboxnet,virbr,ifb,meth