summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThierry Bultel <thierry.bultel@iot.bzh>2018-12-11 15:57:41 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 22:06:10 +0000
commita46a78ad5f2baa90127808ad1c4d025e4b4a0e77 (patch)
treeb0be9dc2a5e4412a3592acf4384a9165a3326d27
parent73351742e32772a19f62086cea5a5e7a38fe02f7 (diff)
bump bluez-alsa to master (brings Ofono support)
This takes the mandatory commits to have HFP support over Ofono (56fcc3 from 2018-12-04) Also adds the needed options to the daemon in the service file The license changed due to change of year and author list It was bogus to have hcitop in PACKAGECONFIG. Namely, this is not a feature in yocto, but only an optional feature of bluez-alsa (that helps to perform bandwith measures) However, Ofono is one. This also adds hcitop and rfcomm tools in development images. Those tools help to diagnose bt issues. Change-Id: I426dbee5aa8911c9c64f4ec7399528d149dc651b Signed-off-by: Thierry Bultel <thierry.bultel@iot.bzh> Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb13
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez-alsa/files/bluez-alsa.service2
2 files changed, 10 insertions, 5 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb b/meta-agl-profile-core/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
index 6379ec38f..6614d2274 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
+++ b/meta-agl-profile-core/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
@@ -3,10 +3,10 @@ HOMEPAGE = "https://github.com/Arkq/bluez-alsa"
SECTION = "libs"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bb3e99e80c5d718213f35ae1def4c106"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=88dc1c98120259ae67b82222d7aff5c1"
SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master"
-SRCREV = "9045edb436ea755f395a2e09e4525b5defad286a"
+SRCREV = "56fcc3215e9a7e0a4576c1bcc544ec9aad2d937f"
SRC_URI += "file://bluez-alsa.service"
@@ -16,7 +16,7 @@ DEPENDS += "alsa-lib bluez5 systemd glib-2.0 sbc"
PACKAGECONFIG[aac] = "--enable-aac, --disable-aac, "
PACKAGECONFIG[aptx] = "--enable-aptx,--disable-aptx,"
-PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
+PACKAGECONFIG[ofono] = "--enable-ofono, --disable-ofono,"
inherit autotools pkgconfig
inherit systemd
@@ -24,7 +24,12 @@ inherit systemd
SYSTEMD_AUTO_ENABLE = "enable"
SYSTEMD_SERVICE_${PN} = "bluez-alsa.service"
-PACKAGECONFIG += "hcitop"
+PACKAGECONFIG += "ofono"
+
+# enable debug tools in devel images
+PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
+PACKAGECONFIG[rfcomm] = "--enable-rfcomm, --disable-rfcomm,"
+PACKAGECONFIG_append_agl-devel = " hcitop rfcomm"
do_install_append () {
install -d ${D}${base_libdir}/systemd/system
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez-alsa/files/bluez-alsa.service b/meta-agl-profile-core/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
index 671815e03..b59302ee4 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
+++ b/meta-agl-profile-core/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
@@ -5,7 +5,7 @@ Requires=bluetooth.service
[Service]
Type=simple
-ExecStart=/usr/bin/bluealsa
+ExecStart=/usr/bin/bluealsa -p a2dp-sink -p hfp-ofono
[Install]
WantedBy=multi-user.target