summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-07 11:49:15 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 21:10:07 +0000
commitbfc73005bcf149a8065683e53939204d02d3517d (patch)
tree45cb08d1851a505268dcdb5433606c32e20093a7
parent60873f9da578054e029208ad64da14d2ceeccbbc (diff)
connman: Tweak main.conf for cluster demo support
When running the cluster demo, we do not want the second ethernet interface managed by connman, as it will be used for a separate connection to the cluster board, and should not be considered part of the shared connection pool. To do this, NetworkInterfaceBlacklist is tweaked if agl-cluster-demo-support is enabled. Change-Id: Iab8c17662bb7f5b06b5eda6c97dd32a6c5ef3f5a Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index 57406fa0a..98729400c 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -9,4 +9,9 @@ FILES_${PN} += "${sysconfdir}/connman/main.conf"
do_install_append() {
install -d ${D}${sysconfdir}/connman
install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+
+ # Need to ignore eth1 in cluster demo setup
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'agl-cluster-demo-support', 'true', 'false', d)}; then
+ echo "NetworkInterfaceBlacklist=vmnet,vboxnet,virbr,ifb,eth1" >> ${D}${sysconfdir}/connman/main.conf
+ fi
}