summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-12-27 17:00:48 +0000
committerJosé Bollo <jose.bollo@iot.bzh>2019-01-02 08:51:39 +0000
commitf6f19bd2d9e74375a6f6cd801ea8d67660ee964e (patch)
tree2e0e235730f5df3bea1ba0ff91bb96018c90eda2
parent7c3a9d14894691ce7c83743f7502bd591f29b2df (diff)
Add afb-helpers & controller libraries
Add the latest controller & afb-helpers libraries with a separated Qt library to avoid dependency problem on AGL image without Qt support Bug-AGL: SPEC-1689 Change-Id: I69d79b35a8dae0749f1947c641f28342c97d461b Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb8
-rw-r--r--meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc14
-rw-r--r--meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb19
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-devtools/libafb-helpers-qt/libafb-helpers-qt_git.bb11
4 files changed, 52 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb b/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
new file mode 100644
index 000000000..1174ac4d7
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
@@ -0,0 +1,8 @@
+require libafb-helpers_git.inc
+
+inherit cmake
+
+RDEPENDS_${PN}_append = " af-binder"
+
+ALLOW_EMPTY_${PN} = "1"
+
diff --git a/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc b/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
new file mode 100644
index 000000000..d3c883e15
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
@@ -0,0 +1,14 @@
+SUMMARY = "AFB helpers library"
+DESCRIPTION = "AFB helpers library to ease JSON object manipulation and binding interaction"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libafb-helpers;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "f430407fd34ec2897359245a6e1ff951e5da5bc6"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS_append = " af-binder"
+
diff --git a/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb b/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
new file mode 100644
index 000000000..dac1640e1
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Controller library for an Application Framework"
+DESCRIPTION = "Controller library to be used to easily create a binding for AGL App Framework"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libappcontroller;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "565e5a7fac5db9a35fd0b2cb8e12f1bdf4772821"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS_append = " af-binder libafb-helpers lua"
+RDEPENDS_${PN}_append = " af-binder lua"
+
+inherit cmake
+
+ALLOW_EMPTY_${PN} = "1"
+
diff --git a/meta-agl-profile-graphical-qt5/recipes-devtools/libafb-helpers-qt/libafb-helpers-qt_git.bb b/meta-agl-profile-graphical-qt5/recipes-devtools/libafb-helpers-qt/libafb-helpers-qt_git.bb
new file mode 100644
index 000000000..802167b2d
--- /dev/null
+++ b/meta-agl-profile-graphical-qt5/recipes-devtools/libafb-helpers-qt/libafb-helpers-qt_git.bb
@@ -0,0 +1,11 @@
+require recipes-devtools/libafb-helpers/libafb-helpers_git.inc
+
+DEPENDS_append = " qtwebsockets"
+RDEPENDS_${PN}_append = " af-binder"
+
+inherit cmake_qt5
+
+EXTRA_OECMAKE_append = " -DAFB_HELPERS_QT=ON -DAFB_HELPERS=OFF"
+
+ALLOW_EMPTY_${PN} = "1"
+