summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-04-02 11:12:22 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2019-04-02 11:12:22 +0000
commitd1c84fd1785d4c3e5a15b3fabfc5a140624859ec (patch)
treee96611189cc6115ceeb9e40edc868d501a01554c
parent88e20d2dd4fdd550d31d0463d1671f54bb093d9a (diff)
parentdd21af780072b16bd27814a5cd347431b3baffdc (diff)
Merge "meta-agl-profile-telematics: recipes-core: systemd: change canbus systemd match regex" into guppy
-rw-r--r--meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can.network (renamed from meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can0.network)2
-rw-r--r--meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend8
-rw-r--r--meta-agl-profile-telematics/recipes-core/systemd/systemd_234.bbappend6
3 files changed, 9 insertions, 7 deletions
diff --git a/meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can0.network b/meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can.network
index 8e548ce59..9768c4bf9 100644
--- a/meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can0.network
+++ b/meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can.network
@@ -1,5 +1,5 @@
[Match]
-Name=can0
+Name=can*
[CAN]
BitRate=500K
diff --git a/meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend b/meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 000000000..5e02b2b24
--- /dev/null
+++ b/meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append = "file://canbus-can.network"
+
+do_install_append() {
+ mkdir -p ${D}${base_libdir}/systemd/network
+ install -m 0644 ${WORKDIR}/canbus-can.network ${D}${base_libdir}/systemd/network/60-canbus-can.network
+}
diff --git a/meta-agl-profile-telematics/recipes-core/systemd/systemd_234.bbappend b/meta-agl-profile-telematics/recipes-core/systemd/systemd_234.bbappend
index a145cc98b..7c49231b2 100644
--- a/meta-agl-profile-telematics/recipes-core/systemd/systemd_234.bbappend
+++ b/meta-agl-profile-telematics/recipes-core/systemd/systemd_234.bbappend
@@ -4,10 +4,4 @@ SRC_URI_append = " \
file://0001-networkd-link-link_configure-factor-out-link_configu.patch \
file://0002-networkd-link-link_up_can-move-function-upwards.patch \
file://0003-networkd-link-add-support-to-configure-CAN-interface.patch \
- file://canbus-can0.network \
"
-
-do_install_append() {
- mkdir -p ${D}${base_libdir}/systemd/network
- install -m 0644 ${WORKDIR}/canbus-can0.network ${D}${base_libdir}/systemd/network/60-canbus-can0.network
-}