aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2019-11-25 13:15:30 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-26 17:52:05 +0000
commitab525dfab8913cd043ce133365e926b42f224d64 (patch)
treefe58db58953924ee05a2913d303970ca5655ff84
parent3a057eb3399bb6c34dfc76b503a6a98839d0ee89 (diff)
graphics: Add agl-compositor recipe
Add a recipe for the new AGL compositor and enable it when building the Weston package group. Change-Id: I3fe88370a4fc6a01b8ba8c3126a407cd9c39a842 Signed-off-by: Daniel Stone <daniels@collabora.com>
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb21
-rw-r--r--meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb1
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
new file mode 100644
index 000000000..f42b2882b
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Reference Wayland compositor for AGL"
+DESCRIPTION = "The AGL compositor is a reference Wayland server for Automotive \
+Grade Linux, using libweston as a base to provide a graphical environment for \
+the automotive environment."
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-compositor"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
+
+DEPENDS = "wayland wayland-protocols wayland-native weston"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "aa4ba5d283d641da25722af7a966c31d61a9686b"
+
+PV = "0.0.10+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig python3native
+
+FILES_${PN} = "${bindir}/agl-compositor"
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb
index 53721f0d2..a97b6ebe2 100644
--- a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb
+++ b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb
@@ -17,5 +17,6 @@ RDEPENDS_${PN} += " \
weston-ready \
agl-login-manager \
agl-desktop-config \
+ agl-compositor \
"