summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2019-11-25 19:25:52 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-26 17:52:24 +0000
commit0eefa345c3554f960f1eb08ab6f5d8f336120d7b (patch)
tree7dac38a79d61adabca2439c1948304289e1a8bd2
parentab525dfab8913cd043ce133365e926b42f224d64 (diff)
agl-compositor: Add DISTRO_FEATURE to enable compositor
When the 'agl-compositor' distro feature is enabled, the AGL compositor will be enabled and start at boot instead of Weston. Change-Id: Idcd0c401c3d2c332637ddde1cd83d1fe85c4ae2a Signed-off-by: Daniel Stone <daniels@collabora.com>
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend2
-rw-r--r--templates/feature/agl-compositor/50_local.conf.inc1
-rw-r--r--templates/feature/agl-compositor/README_feature_agl-compositor.md13
3 files changed, 15 insertions, 1 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
index 398cd1c55..247aeeee3 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit agl-graphical
-WESTONSTART ??= "/usr/bin/weston ${WESTONARGS}"
+WESTONSTART ??= "${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "/usr/bin/agl-compositor", "/usr/bin/weston",d)} ${WESTONARGS}"
WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
DROPIN_NAME = "weston-init"
diff --git a/templates/feature/agl-compositor/50_local.conf.inc b/templates/feature/agl-compositor/50_local.conf.inc
new file mode 100644
index 000000000..be749b799
--- /dev/null
+++ b/templates/feature/agl-compositor/50_local.conf.inc
@@ -0,0 +1 @@
+DISTRO_FEATURES_append = " agl-compositor"
diff --git a/templates/feature/agl-compositor/README_feature_agl-compositor.md b/templates/feature/agl-compositor/README_feature_agl-compositor.md
new file mode 100644
index 000000000..4b5211ee7
--- /dev/null
+++ b/templates/feature/agl-compositor/README_feature_agl-compositor.md
@@ -0,0 +1,13 @@
+---
+description: Feature agl-compositor
+authors: Daniel Stone <daniels@collabora.com>
+---
+
+### Feature agl-compositor
+
+_agl-compositor_ is a new Wayland display server framework, based on the
+existing libweston library. It provides AGL users an extensible framework for
+window/input/output management within the display server.
+
+It is included as a technology preview, and is not currently ready for
+production use.