summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-01-23 18:49:23 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-01-28 16:36:56 +0000
commit6625f61e85a6ce9f058ad17199b461906a2b4795 (patch)
tree35cc10c3798a8c8b7e7a61be03edfcabb0267749
parentacdfb041fad5eb91ad5a415562e12b22c6f86b39 (diff)
af-main: Use xdg-shell-v6 for agl-compositor
As we're using xdg-shell-v6 instead of ivi-shell for agl-compositor and applications, make the transition much easier (that is, having a fully bootable workable image) by making it default when the DISTRO_FEATURES specify it. Bug-AGL: SPEC-3128 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I1bf1546d3cfab14b1b4b76199ba60207c984d69f
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 6e44c4959..66b93db5d 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -85,7 +85,9 @@ do_install_append_class-target() {
ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
fi
- echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
+
+ DEFAULT_WM_SHELL="${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell-v6', 'ivi-shell', d)}"
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${D}${afm_confdir}/unit.env.d/qt-shell
}
pkg_postinst_ontarget_${PN}() {