summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-01-04 04:21:43 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-01-04 03:24:12 +0000
commitb346f282b1c615e29e7b81b4dbe564e39a8e6063 (patch)
tree207b4ca0c2470b26a7b595a2a6bfbd0b0b5220e6
parent840de7fe2b32cdacedbbae371a1191d704ca487d (diff)
Fix hvacplugin cross-compilation issue due to wrong path in CMakeLists.txtalbacore_1.0albacore
Backport from master - urgent. This patch fixes a cross-compilation issue with hvacplugin. The absolute path set for Boost_INCLUDE_DIRS is not cross-compilation save. According to https://cmake.org/Wiki/CMake:How_To_Find_Libraries we better use find_package(Boost REQUIRED) . Otherwise bitbake might fail with: ERROR: QA Issue: hvacplugin: The compile log indicates that host include and/or library paths were used. Please check the log .../hvacplugin/0.1-r0/temp/log.do_compile' for more information. [compile-host-path] ERROR: QA run found fatal errors. Please consider fixing them. ERROR: Function failed: do_package_qa Due to: cc1plus: warning: include location "/usr/include/boost" is unsafe for cross-compilation [-Wpoison-system-directories] Change-Id: I114962b60fdb0162f9e9a88964705cbbba901278 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch48
-rw-r--r--meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch b/meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch
new file mode 100644
index 000000000..c936d8a60
--- /dev/null
+++ b/meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch
@@ -0,0 +1,48 @@
+From 2f29b6dea548be861e6f1d0be1b0b7f83a2b3037 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <dl9pf@gmx.de>
+Date: Mon, 4 Jan 2016 02:19:24 +0100
+Subject: [PATCH] Fix boost include statement
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch fixes a cross-compilation issue with hvacplugin.
+The absolute path set for Boost_INCLUDE_DIRS is not
+cross-compilation save.
+According to https://cmake.org/Wiki/CMake:How_To_Find_Libraries
+we better use find_package(Boost REQUIRED) .
+
+Otherwise bitbake might fail with:
+ERROR: QA Issue: hvacplugin: The compile log indicates that
+ host include and/or library paths were used.
+ Please check the log .../hvacplugin/0.1-r0/temp/log.do_compile'
+ for more information. [compile-host-path]
+ERROR: QA run found fatal errors. Please consider fixing them.
+ERROR: Function failed: do_package_qa
+
+Due to:
+cc1plus: warning: include location "/usr/include/boost" is unsafe
+for cross-compilation [-Wpoison-system-directories]
+
+Signed-off-by: Jan-Simon Möller <dl9pf@gmx.de>
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f8d0e5b..f100736 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,7 +6,8 @@ pkg_check_modules(gio gio-2.0)
+ pkg_check_modules(gio-unix gio-unix-2.0)
+ pkg_check_modules(json-c json-c)
+ pkg_check_modules(amb automotive-message-broker)
+-set(Boost_INCLUDE_DIRS /usr/include/boost)
++#set(Boost_INCLUDE_DIRS /usr/include/boost)
++find_package(Boost REQUIRED)
+
+ include_directories(${CMAKE_SOURCE_DIR}/lib ${include_dirs} ${gio_INCLUDE_DIRS} ${gio-unix_INCLUDE_DIRS} ${CMAKE_SOURCE_DIR}/plugins/common ${Boost_INCLUDE_DIRS} ${json-c_INCLUDE_DIRS} ${amb_INCLUDE_DIRS})
+
+--
+2.6.2
+
diff --git a/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb b/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
index 9692e2d0f..1d73c72f2 100644
--- a/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
+++ b/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
SRC_URI = "git://github.com/iotbzh/hvacplugin \
file://hvacplugin \
+ file://0001-Fix-boost-include-statement.patch \
"
SRCREV = "253e3d98505108f652ba875544fde4f58d4714c8"
S = "${WORKDIR}/git"