summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-05 18:49:47 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-11 17:20:55 +0000
commitda7ba697b82e9f8b7e330254be4f8f99ad4b87cf (patch)
tree0186ee8ade722f7a95052eb36285c0d150a9e0eb
parentbe4e3848ea2c35c9fc380921c54f20c1859bba0f (diff)
meta-agl-bsp: add kernel-devicetree to nogfx rcar3 images
Shift the IMAGE_INSTALL_append of the kernel-devicetree package to agl_rcar-nogfx.inc so that it will be added to the *ulcb-nogfx images in addition to the *uclb images. This fixes booting the nogfx images from SD cards created with the wic.xz image. Bug-AGL: SPEC-3754 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: If4868326f50e45046fcce7b5d6ba43f13f746ec1 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25866 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> (cherry picked from commit 47464de6ae327896b2d2e5047275d933010b5eeb) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25781
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar-nogfx.inc4
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc1
2 files changed, 4 insertions, 1 deletions
diff --git a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
index a7fabfac8..3ffded7c5 100644
--- a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
@@ -7,3 +7,7 @@ OSTREE_BOOTLOADER ?= "u-boot"
WKS_FILE = "singlepart-noloader.wks"
RENESAS_DATADIR = "/usr"
+
+IMAGE_INSTALL_append_rcar-gen3 = " \
+ kernel-devicetree \
+" \ No newline at end of file
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index dd64ae772..cfdff9dbf 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -41,7 +41,6 @@ DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
IMAGE_INSTALL_append_rcar-gen3 = " \
- kernel-devicetree \
kernel-module-pvrsrvkm \
kernel-module-vsp2 \
kernel-module-vspm \